NVivo 10: Introductory workshop
Software Used

*NVivo 10*

Files Used

- 1st Debate Opening Statements_No heading styles.docx
- 2nd Debate Opening Statements.docx
- Final Debate Opening Statements.doc
- Interview with David Cameron.pdf
- Interview with Gordon Brown.pdf
- Interview with Nick Clegg.pdf
- Final debate image.jpg
- Twitter content.nvp
- Question Time.mp4
- Video websites.docx
- Speaker Demographics.xlsx
- PM Debate Library.enl
- PM Debate Library.Data

Revision Information

<table>
<thead>
<tr>
<th>Revision</th>
<th>Date</th>
<th>Authors</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.0</td>
<td>November 2012</td>
<td>Chris Giacomantonio</td>
<td>Original version.</td>
</tr>
<tr>
<td>2.1</td>
<td>February 2013</td>
<td>Chris Giacomantonio</td>
<td>Minor revisions from original.</td>
</tr>
<tr>
<td>3.0</td>
<td>October 2013</td>
<td>Daniel Villar-Onrubia</td>
<td>Revisions to content and structure.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Chrysanthi Papoutsi</td>
<td></td>
</tr>
<tr>
<td>3.1</td>
<td>February 2014</td>
<td>Chrysanthi Papoutsi</td>
<td>Revisions to content and structure.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Daniel Villar-Onrubia</td>
<td></td>
</tr>
</tbody>
</table>

Acknowledgements

Thanks to David Baker at IT Services in Oxford for supporting development of this course. Thanks also to the workshop attendees, whose participation has been essential in shaping this course.
Copyright

This document is made available under a Creative Commons Attribution-NonCommercial-ShareAlike CC-BY-NC-SA licence by Chris Giacomantonio and adapted by Daniel Villar-Onrubia & Chrysanthi Papoutsi, who assert their rights to be identified as the authors.

Note that some images and documents used in the presentation and exercises are copyright of their owners and may be subject to different copyright conditions. Where possible this has been noted in the text. If an error in attribution/copyright has been made, please contact the author who will be pleased to make the necessary corrections.

For those accessing these materials via the IT Portfolio site, please note that the workshop utilizes video content that cannot be distributed in the course materials files. The video exercises will work generally with any small audio or video clip, however.

Screenshots are copyright of the respective software suppliers.
<table>
<thead>
<tr>
<th>CONTENTS</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Welcome to the NVivo 10: Introduction workshop</td>
<td>6</td>
</tr>
<tr>
<td>Workshop Outline</td>
<td>8</td>
</tr>
<tr>
<td>Session 1: Methodological Considerations</td>
<td>9</td>
</tr>
<tr>
<td>One more note</td>
<td>9</td>
</tr>
<tr>
<td>Reading the NVivo Interface</td>
<td>10</td>
</tr>
<tr>
<td>Opening a new project</td>
<td>10</td>
</tr>
<tr>
<td>Inside the project</td>
<td>10</td>
</tr>
<tr>
<td>Basic Terminology: Sources and Nodes</td>
<td>11</td>
</tr>
<tr>
<td>Viewing data in your project</td>
<td>12</td>
</tr>
<tr>
<td>Auto-saving</td>
<td>13</td>
</tr>
<tr>
<td>The NVivo Help system</td>
<td>14</td>
</tr>
<tr>
<td>Getting your research into NVivo</td>
<td>15</td>
</tr>
<tr>
<td>Preparing and importing external data</td>
<td>15</td>
</tr>
<tr>
<td>Creating documents and editing imported sources</td>
<td>16</td>
</tr>
<tr>
<td>Linking external data</td>
<td>16</td>
</tr>
<tr>
<td>Organizing your data using nodes</td>
<td>17</td>
</tr>
<tr>
<td>Preparing text for auto-coding</td>
<td>18</td>
</tr>
<tr>
<td>Precision is essential!</td>
<td>18</td>
</tr>
<tr>
<td>Organizing your data using classifications</td>
<td>19</td>
</tr>
<tr>
<td>Classifications and attributes</td>
<td>19</td>
</tr>
<tr>
<td>Creating source classifications</td>
<td>19</td>
</tr>
<tr>
<td>Creating node classifications</td>
<td>19</td>
</tr>
<tr>
<td>Importing classification sheets through Excel</td>
<td>20</td>
</tr>
<tr>
<td>Editing classifications</td>
<td>21</td>
</tr>
<tr>
<td>Sets</td>
<td>22</td>
</tr>
<tr>
<td>Customizing your interface</td>
<td>23</td>
</tr>
<tr>
<td>Section</td>
<td>Page</td>
</tr>
<tr>
<td>------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Session 2: Doing Analysis</td>
<td>25</td>
</tr>
<tr>
<td>Working with Nodes</td>
<td>26</td>
</tr>
<tr>
<td>A little more about nodes</td>
<td>26</td>
</tr>
<tr>
<td>Coding text</td>
<td>27</td>
</tr>
<tr>
<td>Coding audio and visual media</td>
<td>29</td>
</tr>
<tr>
<td>Visual markers of node coding</td>
<td>30</td>
</tr>
<tr>
<td>Creating a codebook</td>
<td>31</td>
</tr>
<tr>
<td>Querying Data</td>
<td>32</td>
</tr>
<tr>
<td>Word Frequency searches</td>
<td>32</td>
</tr>
<tr>
<td>Text Searches</td>
<td>32</td>
</tr>
<tr>
<td>Coding queries</td>
<td>33</td>
</tr>
<tr>
<td>Compound queries</td>
<td>34</td>
</tr>
<tr>
<td>Saving queries</td>
<td>35</td>
</tr>
<tr>
<td>Links: Memos, Annotations, See Also links, and Hyperlinking</td>
<td>37</td>
</tr>
<tr>
<td>Memos</td>
<td>37</td>
</tr>
<tr>
<td>Annotations</td>
<td>37</td>
</tr>
<tr>
<td>See also links</td>
<td>38</td>
</tr>
<tr>
<td>Hyperlinking</td>
<td>39</td>
</tr>
<tr>
<td>Framework Matrices</td>
<td>39</td>
</tr>
<tr>
<td>Importing reference libraries</td>
<td>40</td>
</tr>
<tr>
<td>Other areas of interest not covered in the workshop</td>
<td>41</td>
</tr>
<tr>
<td>Preparing survey results and other datasets</td>
<td>41</td>
</tr>
<tr>
<td>Relationships</td>
<td>41</td>
</tr>
<tr>
<td>Models</td>
<td>41</td>
</tr>
<tr>
<td>NVivo reports and methodological transparency</td>
<td>41</td>
</tr>
<tr>
<td>Notes and participant questions</td>
<td>42</td>
</tr>
</tbody>
</table>
Below you will find a few notes on what we will (and will not) do in the workshop, as well as some suggestions for revision between the two sessions.

The great thing about NVivo 10 is that QSR provides free tutorial videos and an excellent online help system for all basic and even some intermediate NVivo capabilities. In this workshop we will cover nothing more than QSR provides through online videos, so take this as an opportunity to gain hands-on experience while exploring the software.

We will learn how to do a number of basic tasks that will be useful to most qualitative researchers working with data such as interview transcripts, video and audio files, and images. You will have an opportunity to work with sample data prepared specifically for the workshop, or you can bring your own data and get a head start on your analysis. However, keep in mind that this is not intended as a workshop on your project, and the instruction is designed with general skill-building in mind.

After the first session it would be wise to peruse the NVivo 10 video tutorials, including at minimum Get up and running with NVivo 10. Each video is only about 8-12 minutes in length, so watching three or four of the videos listed specifically as NVivo 10 should be useful without being too onerous. We also recommend you to consult the document Data Management for Qualitative Data Using NVivo. You may work with the program either by downloading it to your home computer through the QSR Website and getting a license key from the IT services Software Registration page or by using NVivo on an Oxford computer operating the remote server version.

You should be aware that the Oxford server version, and the one we will use in the workshop, is version 10, while many computers at Oxford still use version 9.0, and some use 9.2. The basics of what we cover in the workshops will be relevant for any of these, but if you decide to work on some of your own work during the class activities, you should be aware that you will not be able to open a file created in 9.2 or 10 in the 9.0 software. NVivo projects created in versions before 9.2 can be opened on all later versions through a conversion that the software performs.

During the workshop, we will do some hands-on exercises based on the three UK Prime Ministerial Debates from 2010 (apologies to any participants who don’t like politics!). Transcripts from each of these can be found on the BBC Debates Pages. The videos for these are all available online at these sites:

Debate 1 (ITV)  Debate 2 (Sky News)  Debate 3 (BBC)

It is not necessary to watch or read all of these in full, but to review them for general content will speed up your progress in the subsequent activities, especially during the second session of the workshop.
If you have your own data and would prefer to make this an opportunity to explore it through NVivo, please feel free to do so. To be able to participate in all activities, you will need at least two interview transcripts, one audio or video file, and some demographic data on your interviewees. You are welcome to bring along as large a data set as you like, and will find the workshop more interesting with at least three or four pieces of data to work between. These can include data such as transcripts (with one or more participants), audio and video files, field diaries, academic articles, images, news stories, websites, and more. If you do bring your own data, keep in mind that the exercises are designed for the provided data set, and so the instructors may not be able to answer all of your questions or provide support for your analysis.

Lastly, at the end of the workshop we will leave some time to address specific questions from participants. The instructors cannot guarantee that they will be able to answer every question on NVivo, but if you submit your questions beforehand by email, they will do their best to come prepared with an answer.
## WORKSHOP OUTLINE

The agenda for the workshop is as follows:

### Session 1 – Importing and organising data
- What can NVivo do for you?
- Inside NVivo
- Getting your research into NVivo
- Organising and editing data
  - People nodes
  - Coding at people nodes
  - Auto-coding
  - Source classifications
  - Node classifications
  - Sets
- Customising your interface
- Terminology
- How to get the license and the software
- Questions

### Session 2 – Analysing data
- Recap from session 1
- Doing analysis
- Coding at thematic nodes
  - Parent nodes and child nodes
  - Visual markers of node coding
  - Coding: quick, in vivo and un-coding
  - Coding audio and visual media
- Creating a codebook
- Querying data
  - Word frequency searches
  - Text searches
  - Coding queries
  - Saving queries
- Other functionality
  - Memos
  - See also Links
  - Framework matrices
  - Importing reference libraries
- Questions
Is NVivo right for you?

The first question you need to consider before engaging in NVivo-based analysis has to be whether or not NVivo will add value to your analysis (or possibly make your life easier). You therefore need to think about what you are trying to achieve as a researcher and analyst. Of course, for novice users it will be hard to know if NVivo is right, before knowing what it can and can’t do. So, we will begin the workshop with a discussion of these issues in light of the participants’ research intentions.

NVivo can be quite useful for data sets of various sizes, mixed media and mixed methods data, and small or large team research projects through its team-work and cloud server functionality. It has broad capabilities and its interface is user-friendly relative to other similar programs. It is becoming an industry standard for archiving qualitative data as it is recommended by the UK Data Archive, so understanding it is worthwhile for researchers who plan on doing Research Council-supported projects. It is also free to Oxford students and staff on a site license.

However, it has its limitations and, unlike statistical analysis software for quantitative research, it is more ancillary than fundamental as a component of most qualitative projects. At minimum, it is worth remembering the following:

- NVivo can do very little analysis for you, and it relies heavily on user input
- Learning NVivo takes work (this workshop won’t be enough!)
- Organizing data into NVivo takes more work
- There may be easier solutions, especially for simple tasks
- Examining data through NVivo can limit your analytic frame
- NVivo is known to run slowly or crash, especially on older computers

With these things in mind, there are still lots of good reasons to learn the software and many ways it can assist your analysis, help organize your thinking, and keep your data in order.

Before we engage in any data preparation, organization, and analysis, it is worth keeping in mind that there are many ways to approach a task in NVivo. The program provides multiple paths to fundamentally similar ends. What is important is that your strategy is suited to what you want to accomplish with your analysis.

ONE MORE NOTE...

Keep in mind that the following is not an exhaustive list of the approaches to analysis and functions available to NVivo users. Instead, the workshop will lay out a few essential skills that will be applicable for a wide range of research projects, and hopefully provide participants with the tools to self-teach some more intermediate functions.
READING THE NVIVO INTERFACE

We will just quickly walk through the basics of what you see in your first moments with the program. You may want to watch the introductory video later on to revise this on your own.

OPENING A NEW PROJECT

When you open the program you will see a “Welcome” screen that lists all of your recent projects, and has buttons for New Project, Open Project, and Help.

![New Project, Open Project, Help buttons]

When you click on New Project, a dialogue box will open asking for a file name and description for the project. You must enter a file name, which also sets a default file path. You can also enter a description of the project, though this is optional. When you click OK, your project will open.

![New Project dialogue box]

Exercise

Create a project! Leave the “Log Project Events” button unchecked, as this is normally used for team research projects.

INSIDE THE PROJECT

NVivo uses a ribbon-guide menu that looks like this:
You will notice that most icons on the ribbon are initially presented in greyscale when you open the program, which means they are not usable until an appropriate internal referent (e.g. a data source, node, table, etc) has been selected or opened. So, you will need to import some data before you can start exploring NVivo. The more kinds of data you have, the more you can explore the program!

The ribbon-guide buttons each have a roll-over text box providing a description of its function(s). This means that when you run the mouse arrow over one of these icons, it will tell you what it does. It is a good idea to do this with each button to familiarize yourself with the tools available to you.

At the outset, the most important tabs and buttons for you will probably be the following:

**Create:** This tab allows you to create new sources of data from scratch, new nodes for organization and analysis, new collections and classifications, and so on. You can also create “External” sources, which are external data not suitable for importing, such as large video files or webpages. You can add notes to describe these, which make them internally searchable and codeable.

The create functions can all be achieved by right-clicking in a window within the appropriate location in your project, but until you know where that is, this tab will provide you with all of the one-click shortcuts you need to create data and organize it.

**External Data:** This tab allows you to import data prepared elsewhere for NVivo, including transcripts, datasets, audio and video files, classification sheets, academic articles and even your reference library.

**Analyze:** This tab includes all of the commands for coding, which will be dealt with later in the workshop.

**Query:** NVivo 10 introduces a separate menu for queries, which used to be housed under the Explore menu. Queries provide ways of seeking specified patterns in your data through user-defined parameters.

**Explore:** Provides tools for seeing patterns in your data, such as word searches and counts, visualizations of content and coding, and creating reports of your NVivo analysis.

**Layout:** While we will not deal with tables in this workshop, the Layout tab holds all of the tools for manipulating tables in internal sources.

---

**BASIC TERMINOLOGY: SOURCES AND NODES**

Working with NVivo 9 is much easier once you understand the basic terminology. NVivo Help provides an easy-to-use glossary that is available on its navigation sidebar:
Two essential terms for NVivo skills development are **sources** and **nodes**.

A source is a term for any research material that you have connected to your NVivo project. This could be transcripts or field notes, as well as academic articles, research plans, pictures, audio recordings, videos, notes, and online materials.

A node is best thought of as a “container” in which wholes or parts of sources are kept for analysis. While NVivo offers users many ways to group and organize their data, nodes offer the richest avenue for subsequent analysis. This will become clearer as the workshop progresses.

For those who have some familiarity with NVivo 8, do note that NVivo 9 and later versions have eliminated Tree Nodes (though these are largely the same as parent and child nodes), and also eliminated Case Nodes (which are essentially replaced by node classifications).

**VIEWING DATA IN YOUR PROJECT**

Once you have sources and nodes in your project, these will be visible in a **List View** window when you click the **Sources** or **Nodes** buttons on the **Navigation View** sidebar. If you double-click on a source, it will open below in what is called **Detail View**.
To find sources or nodes by name, you can quickly bring them up using the Find bar, located above the List View window. Simply type in all or part of the name in the Look for box, and a list of relevant items will appear.

To find content within a source, open the source in Detail View and click the Find button under the Home tab.

AUTO-SAVING

The NVivo program is set by default to give you reminders to save your project every 15 minutes that you have gone without saving. This is particularly important since your project will not create backup versions of itself automatically, and NVivo is a complex program that has been known to crash, potentially ruining hours of work.

To save you from this fate, NVivo will present you with this window:

By clicking Yes, you will save any changes you have made to the project, which you would then have to manually undo. If you are experimenting with your data, you may want to change the frequency of save reminders or turn this function off to avoid unwanted saves, by going through the following:

File → Options → Notifications tab.
THE NVIVO HELP SYSTEM

NVivo’s Help system (the small ![icon] in the upper right-hand corner) is essential when experimenting with NVivo’s functionality or when you run into a problem. The program is massive and in some cases not necessarily intuitive. It is, however, very usable if you learn how to learn about it. As such, this workshop document has been hyperlinked wherever possible to NVivo’s Help system, to encourage you to familiarize yourself with that system.

The most up-to-date version will always be the online Help version, but you can also access NVivo help when you are offline. If you wish, you can set offline help as the default help mode through the Application Options → General tab (instructions here), to avoid having to open a web browser every time you have a question.

NVivo’s terminology can sometimes be confusing. Below you can find a brief glossary of key terms linked to the kinds of tasks a qualitative researcher may want to ask NVivo to perform. These are not exhaustive, but may assist you in conceiving of Help system queries.

<table>
<thead>
<tr>
<th>I want to…</th>
<th>NVivo equivalent</th>
<th>Relevant Help Section(s)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bring documents, transcripts, datasets, audio or visual material into my project</td>
<td>Import external data</td>
<td>Import documents and PDFs Import data from spreadsheets Import data from database tables Import audio or video Import pictures</td>
</tr>
<tr>
<td>Create a document or transcript within NVivo</td>
<td>Create internal data</td>
<td>About sources Create audio or video transcripts in NVivo</td>
</tr>
<tr>
<td>Include external files or websites for analysis</td>
<td>Create external data</td>
<td>Create externals for sources you cannot import</td>
</tr>
<tr>
<td>Arrange my data items by type (e.g. transcript, article, newspaper)</td>
<td>Create source classifications</td>
<td>Create source classifications</td>
</tr>
<tr>
<td>Arrange my data items into groups</td>
<td>Create a collection</td>
<td>Create and manage sets</td>
</tr>
<tr>
<td>Make a general note to myself or other project members</td>
<td>Create a memo</td>
<td>Create or import memos</td>
</tr>
<tr>
<td>Make a specific note about individual an individual project item</td>
<td>Link a memo</td>
<td>Add, delete and manage memo links</td>
</tr>
<tr>
<td>Sort my data into emerging themes</td>
<td>Code source data into nodes</td>
<td>Basic Coding in Documents, PDFs and External Memos</td>
</tr>
<tr>
<td>Sort text data into pre-defined categories</td>
<td>Auto-code sources</td>
<td>Automatic coding in document sources Automatic coding in dataset sources</td>
</tr>
<tr>
<td>Identify demographic information for people in my study</td>
<td>Create node classifications</td>
<td>Create node classifications Work with attribute values Classify nodes (set attribute values to</td>
</tr>
</tbody>
</table>
Before you can do anything meaningful in NVivo, you need to have some data to work with. There are two ways to get analysable data in NVivo: import it from external files, or create it inside NVivo.

**PREPARING AND IMPORTING EXTERNAL DATA (INTERNAL SOURCES)**

Data can be imported into NVivo using the External Data tab and selecting the kind of material you want to import.

NVivo will accept many standard formats for documents, spreadsheets, images, audio, and video sources. You can import sources one at a time or you can bring in entire collections by CTRL-clicking or SHIFT-clicking the files you want in the appropriate window.

You can also import Twitter content, webpages, Facebook wall posts and comments, and LinkedIn group discussions, by using the NCapture web browser extension. If NCapture is not already installed on the version of NVivo you are working with, you can download it here. When you have installed and authorised the addition of this extension to your web browser, you will be able to capture webpages or social media content by clicking on the NCapture button, usually found on the upper right hand corner of your browser. To import the content you have captured in your NVivo project, click on the From Other Sources button under the External Data tab and select the NCapture option from the drop-down menu.

**Exercise**

Import all files in the “Data sources” folder on your H: drive. You can then organise your files in different folders by type of source, e.g. debates, interviews, images and videos.
**CREATING DOCUMENTS AND EDITING IMPORTED SOURCES**

You can **create documents** inside the NVivo program under the Create tab. NVivo has a limited internal word processor suitable for most basic tasks. Formatting tools can be found under the Home tab.

In certain instances, you may need to apply formatting to documents or spreadsheets to make them useful in NVivo. Below, we will examine some formatting requirements for Word documents and Excel files. In all cases, you will need to ensure that protections (including passwords) are removed from documents before they can be opened by NVivo.

If you need to **edit a document** after you have created or imported it, you can do this by opening the source and clicking **Edit** under the Home tab or the **Click to Edit** button that appears at the top of the opened document in the Detail View window. Editing an imported source does not affect the original external file.

If you would like to work with an internal document source in an external program, you can **export the document** as any of the supported file formats and edit it elsewhere, by selecting the document and clicking the **Export** button under the External Data tab. You can alternately right-click the document in the menu and select **Export**.

Remember that if you edit an exported document, you will need to import it again to have the edited version available in your NVivo project.

**LINKING EXTERNAL DATA (EXTERNAL SOURCES)**

In some instances it will not be possible or wise to import a file into your NVivo project. This will be true where the file is very large (which can slow down the program), where it is an online resource, or where it is something that could not be opened by NVivo (such as a hard copy of a book or an SPSS project). External data can be linked through the Create tab by clicking the External button.

Once a file or website has been linked as an external source, a window will open where you can add notes, passages, or other text that will be searchable and codeable in analysis phases. To access the actual file, right-click the external source and select **Open External File**, which will take you outside of the program and into your external file or website.

Do note that, if you link to an external file on a specific computer, you need to be on that computer to be able to access that external data.

You can also create an external without linking to a file or website, by selecting Other under the Type menu in the External tab of the New External dialogue box.
**Exercise**

Link the online videos of the debates to your project as external sources. You can find the URLs in the ‘Video websites’ file on your H: drive.

Give them each a name and add some notes for each one under the **General** tab in the **New External** dialogue box. Then, add each one as a **Web Link** under the **External** tab in the same window, and specify the URL.

---

**ORGANIZING YOUR DATA USING NODES**

As explained earlier, nodes can be thought of as “containers” in which wholes or parts of sources are kept for analysis. When importing data into your project, it might be useful to start organising your sources by coding them at nodes that represent research participants (people nodes), organisations (organisation nodes) or any other unit of analysis that makes sense in the context of your project.

To create a node, click on **Node** under the **Create** tab. You will need to name the node, and you can also provide a description of the node that will remind you (and project team members, if you have them) what kind of data should be placed under that node. You will then manually add data to that node through coding, which we deal with in a later section (see ‘Working with nodes’).

When you have imported and organised your data, you will follow the same process to continue the analysis by creating **thematic** nodes, which capture analytical categories, rather than the origin of your sources or content. We will cover this in more detail in session 2.

---

**Exercise**

Create a people node for one of the speakers in the debate files.

Under Nodes create a new folder named ‘People’. Select this folder and then click **Node** under the **Create** tab. Name your node.
PREPARING TEXT FOR AUTO-CODING

In many cases – especially where you are using NVivo to explore largely unstructured data or to hunt for good quotes in a pile of interviews, you will not need to do any document preparation. However, for more structured analysis, there are a few key steps that can open up NVivo’s capabilities.

It is normally going to be easier to prepare data for importing into NVivo than to manipulate it once it has been imported. For most users, it will be preferable to prepare your documents in Word format (either .doc or .docx) for subsequent ease of use. In particular, NVivo has been designed to recognize Word document heading styles for use in its Auto-Coding functions.

Auto-Coding allows the researcher to quickly aggregate text information through previously-assigned categories. A normal way to use this function would be in instances where a structured interview or questionnaire has been administered as part of a study, and the researcher wants to aggregate all answers to a particular question from multiple respondents. Auto-coding can also be used to separate individual speakers out of group interviews, as well as more creatively to organize semi- or un-structured pieces of data.

For this to be possible, categories in all sources must be arranged under headings that are exactly the same, and from these headings, NVivo will be able to separate and collect these responses into analogous categories as nodes in your project.

Exercise

Using the opening statements from each debate transcript, use heading styles to separate text by speaker name.

If you have prepared the files outside of NVivo, import your prepared transcripts.

Finally, select your prepared transcripts in List View. Then click Auto Code under the Analyze tab and follow the instructions. Code them into new nodes under the heading “Debate Speakers”.

PRECISION IS ESSENTIAL!

NVivo does not make decisions or corrections for you, and small errors in text or format can complicate or negate your use of import functions and other automatic processes in NVivo. For example, if you want to auto-code interview responses, a small typo – including an extra space or punctuation in the heading line – can result in a response being left out of the appropriate node.

You should therefore design strategies at the front end to minimize the chance for errors, such as developing templates for transcripts or quality-checking transcripts prepared by yourself and others.
Once you have imported your data, it is time to organize it for analysis (recognizing that for many researchers, organization and analysis are sometimes concurrent and sometimes in opposition!). As noted earlier, your organization choices will be specific to the kinds of analysis you want to perform.

**CLASSIFICATIONS AND ATTRIBUTES**

Classifications provide a way of arranging and rearranging sources and nodes for analysis. Attributes provide ways of subdividing and refining classifications by adding numeric or text values to a classified source or node.

Source classifications allow the researcher to organize their data sources by type. Node classifications provide a similar function for nodes, and node classification attributes allow more complex queries in analysis stages. We will explore some of the standard approaches to source and node classification.

**CREATING SOURCE CLASSIFICATIONS**

Source classifications can be created under the Create tab by clicking Source Classification and following subsequent instructions. The NVivo program comes with a number of pre-defined source classification options, and users may also define their own classifications.

Users may then add attributes to each classification. You can add attributes to the classification by clicking the Classifications button in the Navigation View sidebar, opening the Source Classifications folder, right-clicking the classification you want to specify, and selecting New Attribute.

As always, refer to the relevant help section if you get stuck.

**Exercise**

Create classifications for the internal sources in your project.

**CREATING NODE CLASSIFICATIONS**

The process for creating node classifications is the same as for source classifications described above, substituting “node” for “source” in each instance.

It may be useful for you to add demographic information regarding participants, or other details about sources, places, people, incidents, experiences, or any other aspect of your project. In previous versions of NVivo, these were known as “cases”.

You can use a node classification to create a case, for example, to separate responses of individual participants or to assemble all data from a particular location or organization into single nodes. When considering your classification and attribute structure, think about categories that will be
helpful in separating your data. A common structure for a node classification used for demographic
details can be found here, but there are many ways to approach this problem.

Classifying nodes will give you increased analytic abilities. For example, you may want to be able to
know how many people over 40 answered a question in a certain way or how often participants
from a certain geographic area mentioned a specific idea or term. This is best achieved through
using node classifications and attributes. The thought process behind this task is rather complicated
to explain in text, so in the workshop we will do this through an exercise instead. Please feel free to
consult the relevant help section for further clarification.

**IMPORTING CLASSIFICATION SHEETS THROUGH EXCEL**

You can prepare classification sheets for importation into NVivo. This is particularly handy if you
have already collected your data in another program prior to using NVivo. A classification sheet in
Excel should have the following format before importing:

<table>
<thead>
<tr>
<th>Classification name</th>
<th>Attribute 1</th>
<th>Attribute 2</th>
<th>Attribute 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>Item name 1</td>
<td>Value</td>
<td>Value</td>
<td>Value</td>
</tr>
<tr>
<td>Item name 2</td>
<td>Value</td>
<td>Value</td>
<td>Value</td>
</tr>
<tr>
<td>Item name 3</td>
<td>Value</td>
<td>Value</td>
<td>Value</td>
</tr>
</tbody>
</table>

You can also import tab-separated text files if that is more suitable to your data.

Once you have a properly-formatted classification sheet, you can import it through the **External
Data** tab by clicking on the **Classification Sheets** button:

This will open the Import Classification Sheets wizard, which will guide you through the process:

Refer to the help sections if you get stuck, and make sure your source file (the Excel file) is not open
on your computer when you try to import it.
Exercise

We have by now created nodes for each debate speaker. Next, we will add some demographic variables about them by creating a Node Classification sheet in Excel.

Beginning with the supplied file containing ages of candidates and moderators, prepare an Excel sheet to classify each speaker in the debate by party affiliation, age range, and gender.

Then, import it using the Import Classification Sheet wizard. Be sure to check the “Replace attribute values...” box in step 2. This will allow NVivo to match your sheet to the Debate Speaker nodes.

Once completed, check out the new node classifications and attributes under the Classifications section.

If you prefer (or would like to try both ways), you can create the node classifications and attributes inside the program.

EDITING CLASSIFICATIONS

All classifications, attributes, and attribute values can be subsequently edited if the categories you want to use change during analysis. The NVivo program will maintain sources or nodes included under an old classification or attribute in the re-named version. It will also offer you the opportunity to re-assign and add values if you change your attribute value structure, so with a bit of care you should be able to painlessly re-name and re-structure classifications as often as necessary.

Exercise

Add “Female” as an attribute value under the Gender column in your node classification.
SETS

Sets are another way of organizing sources and nodes into groups for subsequent analysis. Sets are a kind of Collection, and Collections are handy because they can contain both sources and nodes at the same time, and can be searched using NVivo’s query functions.

To create a set, go to the Create tab and click Set under the Collections group. Name your set, describe it if you wish, and then click OK. You can then add any node or source to your set by right-clicking the item and selecting Add To Set from the menu that appears.

Exercise

Create a set for visual materials in the project, and add all relevant sources to it.
CUSTOMIZING YOUR INTERFACE

If you decide to use NVivo for your project, you will spend many hours in front of it. Customizing can make this experience more pleasant and productive. There are a number of small changes you can make to the layout of NVivo to suit your personal working style and preferences. The following are some of the basic options you may want to know about.

THE RIBBON GUIDE

As noted above, NVivo uses a ribbon-guide menu system rather than drop-down lists. If you want to maximize screen space, you can right-click an empty space on the ribbon and select Minimize the Ribbon, or double-click on any ribbon tab to hide the ribbon icons, for the following layout:

The ribbon can be opened up again temporarily by single-clicking a tab, or permanently by double-clicking any of the tabs.

SIDEBARS

To further maximize screen space, the Navigation View sidebar, the Find toolbar, and the Quick Coding toolbar can all be shown or hidden through the View tab. Do note that if you hide the Navigation View, the Go icon under the Home tab provides the same navigation ability.

You can also modify the Navigation View sidebar to remove any buttons that are not relevant to or regularly used in your project. This can be done through right-clicking anywhere on the sidebar and selecting Navigation Pane Options, which will open a dialogue box where you select the buttons to display. So, if your project contains no collections, for example, you can remove that button to save space.
DOCKING WINDOWS

Once you have imported data into your project, you will want to open data sources to read, code and otherwise analyse them. You have the option of opening these in your project window ("docked"), or in a separate window “undocked”.

Exercise

Once you have successfully prepared, imported and organized a dataset into your NVivo project, take a few minutes to explore interface customizations and other program functions as you see fit. This should enhance your experience of analysis in our second session.
Once you have some or all of your data imported or linked to your NVivo project, and hopefully have it at least somewhat organized, you are in a position to begin analysing it. In the second session, we will look at some of the tools that can assist you in reading your data, recording insights, linking pieces of data together, and sorting relevant findings into themes.

This workshop is not a substitute for qualitative research training. Achieving results through NVivo begins and ends with solid ideas about what qualitative data analysis can do and what you want to accomplish in your project. NVivo can help keep large data sets organized, structure your thinking about certain questions, and provide means to creatively explore your data. It cannot tell you what your data says about your research problem, and in almost all cases you will still have to read (or watch, or listen to, or otherwise examine) your data carefully before drawing conclusions.
WORKING WITH NODES

A LITTLE MORE ABOUT NODES...

In the first session we created people nodes through manual coding and auto-coding. In these cases, each node represented a pre-defined category for information. However, many forms of qualitative inquiry rely on inductive approaches, where categories for data analysis emerge after data collection is completed. In this sense, nodes can also be understood as thematic categories, and can be created during analysis. Sorting your data into nodes through manual coding can be as structured or unstructured as is appropriate to your research method.

PARENT NODES AND CHILD NODES

When you start to think about creating nodes, you may want to develop a coding hierarchy. For example, if a theme emerges that is very general, and you want to sub-divide elements of that theme when sorting data through coding, you can create a parent node for the broader theme and child nodes for the specific sub-themes. To create a child node, right-click on one of your existing nodes and select New Node from the drop-down list. The new node will be created as a child of the selected node, which then becomes the parent.

If you want all of the data coded to child nodes to be available in detail view when you view the content of the parent node, click the Aggregate box when creating a parent node. If you want to enable this function after the node has been created, open up the Node Properties box and select Aggregate.
Exercise

Create at least two new nodes based on themes you have found in the Prime Ministerial Debates (or, if using your own data, create nodes for coding that). Under one of your new nodes, create two child nodes as well.

REORGANIZING NODES

Parent and child nodes can be re-organized as the project progresses. They can be moved between different levels of hierarchy and assigned to new parent nodes where appropriate. You can re-organize using drag-and-drop, cut-and-paste, or merge functions. You can re-name nodes, create new nodes from multiple old nodes, and re-code sources and data as you see fit. Your coding structure can therefore be as fluid or rigid as you like.

CODING TEXT

When you are examining your data, you may see a passage or quote in a text source that you think is important to your analysis. To record that passage or quote and store it in the appropriate node, simply select the text you want with the mouse cursor. Each coded selection is called a “reference”. You can then place that reference in an existing node by selecting Code Selection At Existing Nodes under the Analyze tab and then selecting the appropriate node in the dialogue box:

You can also code at existing nodes by right-clicking the reference and selecting Code Selection → At Existing Node from the menu that appears; by using drag-and-drop coding, dragging the highlighted text from the Detail View window to the node in the List View window; or by using the quick-coding toolbar, which can normally be found at the bottom of the NVivo interface and looks like this:

You can make a new node for the reference by selecting Code Selection At New Node under the Analyze tab, which will then bring up a New Node dialogue window, which you would fill in as if you were creating a node from scratch. You can also get here by right-clicking on the content and selecting Code Selection → At New Node from the menu that appears.
Finally, you can code “In Vivo”, which means that the selected text will become the name of a new node that will be instantly created. This is a useful function when you come across a key phrase or term that you expect to see repeated in other sources. You can do this by highlighting a passage and selecting **Code In Vivo** under the **Analyze** tab, by right-clicking the highlighted passage and selecting **Code In Vivo**, or by pressing CTRL+F8.

Keep in mind that you can code any piece of data at an unlimited number of nodes, so do not worry if you think a passage is relevant to multiple areas of your project. You can make it a reference in as many nodes as you like.

**VIEWING NODES IN DETAIL VIEW**

All data coded to a node will then be available when you **open up that node in the detail view**. Nodes can be viewed in three ways, under separate tabs found on the right-hand side of the open node while in detail view. These are:

- **Summary**: Shows you a list view of all sources coded at that node
- **Reference**: Shows linking and percent coverage of coding at each node
- **Text**: Combines Summary and Reference views

Under the **Reference** and **Text** tabs, you will see a hyperlink to that source that you can click to take you directly into the place in the source that holds the specific piece of data. You will also be able to see how many references were coded from that source to the node and how much of the source is covered by each reference.

If you want to see your reference in context, you can also use the **Spread Coding** function under the **Analyze** tab to see a text on either side of the selection.

The coding spread can be made for a custom range, and may be particularly useful if you prefer to code key words rather than whole passages.
CODING WHOLE SOURCES

You can also code whole sources to nodes by selecting a source (or multiple sources) in the Sources list view and then clicking Code Sources At New Node (or Existing Nodes) under the Analyze tab.

UNCODING

If you change your coding structure or no longer think something is relevant to a certain node, you can remove coding from references or parts of references coded in a source. You can uncode a reference through the Analyze tab, or by selecting the passage you want to uncode, right-clicking and selecting Uncode Selection at the relevant node.

Exercise

Spend 30 minutes coding the material in the debates, pdf articles, and other sources. Use your existing nodes or create new ones. Try using the Quick Coding bar, the Code In Vivo functions, and uncoding.

CODING AUDIO AND VISUAL MEDIA

You can use most of the same coding techniques on audio and video that you use with text. If you have an audio or video file inside your project, you can open it in NVivo. It will create a waveform representing the audio file. You can click-and-drag your mouse cursor over sections of the waveform and code them as if they were text.

As with text sources, when viewing audio or video references in the node in Detail View, you will see how much of the source is covered by the reference. You will also be given a hyperlink to the selection. Clicking on the link will open up the audio or video source and take you to the beginning of the reference, which you can then play through the NVivo media player.

You can also code image files. This is done by click-and-dragging your mouse cursor over the area of a picture that you would like to code, and then coding appropriately. You can add descriptive text to picture sources, and this can be coded like regular text.

Exercise

Using the supplied video file, code a section of the waveform to an existing node. Close the file, then open up the node and use the hyperlink to return to the reference.

AUDIO AND VIDEO TRANSCRIPTS

Using NVivo’s media player, you can create a transcript using the program’s transcription functions. NVivo has all of the functionality of a basic scribe software package.
You can also import a transcript, and if your transcripts are prepared with appropriate timestamps you will be able to use NVivo’s transcript synchronization functions. These will allow you to read through a transcript in sync while its audio or video file is playing. It also lets you code references from transcript text and have these linked in the node to your audio file as well.

**VISUAL MARKERS OF NODE CODING**

You may want to be able to see how much of a source has been coded, and where. NVivo thus gives you the ability to add **Highlighting** and **Coding Stripes** to either some or all of your nodes. Highlighting will highlight the text in the source to show where coding has occurred, while coding stripes provide a visual representation in a new sidebar. Adding coding stripes will also show you **Coding Density**, which reveals you how many times a particular reference has been coded at separate nodes.

To add coding stripes or highlighting, go to the **View** tab and select **Highlight** or **Coding Stripes**. From the drop-down menu that appears, select the nodes you would like to visualize. These can be turned on and off as necessary.

When you code audio, video, or image sources, you can create a visual marker of the coding in the source called Shadow Coding. These are similar to highlighting, and can be switched on or off in the same place as Highlighting and Coding Stripes in the View tab.

**Exercise**

*Add coding stripes to your nodes.*
CREATING A CODEBOOK

You can use a codebook to record definitions of your nodes, capture how your coding has evolved, present representative examples of your coding, or even document exclusion and inclusion criteria for the content that should be coded under a specific node. A codebook captures the intended meaning for each of the nodes so that these can be applied as consistently as possible through time and between different members of the research team.

You can attach definitions to each of your nodes by right-clicking on them in List View, then choosing Node properties and adding a definition to the Description box.

To create a codebook, you would then need to run a report that lists the nodes and their descriptions. Under the Explore tab, choose New report: via Wizard. A new window will open where you will need to choose the option From a View: Node. In the next screen expand the menu under Node and choose the fields you would like to include in your report (in this case Name and Description). Click Next until you are asked to name your report. You will then be able to view the codebook under the option Reports in the Navigation View sidebar.

Alternatively, you can download a codebook template and import it in your project. See here for some useful tips on creating code definitions and keeping track of evolving coding schemes.

Exercise

Create a codebook for the nodes you have created in your project. Experiment with adding and removing different fields from the report.
Alongside sorting your data into nodes, you can run a number of processes to learn more about what is in your data. We have already examined auto-coding, and there are a number of other tools that may provide insight into text-based and coded sources. You can run queries for all of your project, or for a selected group of sources, nodes, sets, folders, and/or annotations and memos. All of the query functions can be found under the **Query** tab.

### Word Frequency Searches

You can find out how many times a specific word or group of related words can be found in all of your data, or in a selected part of it. To find the most common words in your data, you can run a **Word Frequency Query**. This is the most basic query function, and will query selected text sources in your project for the most frequent words. You can specify how many words you would like to see as well as a minimum length, to avoid words like “I”, “a” and “the”.

To run a word frequency query, select it under the **Query** tab, set your parameters and click on the bottom left corner of the dialogue box. You will see that the program creates your results in detail view under four tabs on the right-hand side: Summary, Tag Cloud, Tree Map, and Cluster Analysis. Each of these provides a different way of visualizing your query.

**Exercise**

*Run a word frequency query for your project. Examine the Tag Cloud, Tree Map, and Cluster Analysis. What do these things tell you about your data?*

*Re-try your research, but eliminate shorter words or move the Finding Matches bar from “Exact” to “Similar”. What happens?*

### Text Searches

Text searches provide another way to determine how often certain words appear in your data and annotations. You can also use a text search to find out how many times a certain word appears in context with another word or phrase.

To **run a text search**, select it under the **Query** tab and enter the word or phrase you would like to find in the **Search for** section of the dialogue box. You can specify your search further by looking for
exact matches or similar phrases, and you can also limit your search to within selected areas of your project.

You can also add special instructions within the text box by clicking the button on the right-hand side of the box. These allow you to add Boolean modifiers to your query, as well as specify other words that should be nearby by clicking the Near option. This can help narrow your search significantly in a large dataset.

Once you have set your parameters, click Run. Like viewing a Node in detail view, a Text Search Query creates Summary, Reference, and Text sections. Also like node coding, you can spread your text search coding so that surrounding text is included in detail view.

Running a text search query will also create a Word Tree, which shows you a visual representation of words that occur near the text you are seeking.

**Exercise**

*Run a text search query and examine the results. Try using the Special instructions to narrow your search.*

**CODING QUERIES**

If you want to look in more detail at the coding you have done, you can run a coding query. These allow you to examine coding within a single node to see what kinds of patterns may emerge. You can look for content coded at a specific node, cross-referenced with another node or set of nodes, sources, collections, classifications, and so on. This is a way of looking for overlap between categories, as well as specifying results within categories.

To run a coding query on a node, select that node under the Node section in the Coding Query dialogue box. Then, to specify the areas of that node coding you would like to draw out, choose Selected Items or Items in Selected Folders under the In menu and click Select.
You can then narrow your query in the Select Project Items dialogue box that appears.

Using coding queries, you can also separate responses by attribute values, such as those demographic variables you set out in your classification sheet. This is done by selecting the button and choosing the attributes you want to isolate. You can then define the subset of sources you want to examine in the same way as described above, by choosing Selected Items or Items from Selected Folders under the In menu and setting parameters through the dialogue box that appears.

**Exercise**

*Using a coding query, find all of the text from the debate opening statements made by people under 50 years old.*

**COMPOUND QUERIES**

Compound queries allow you to combine a text search query with a coding query, or to combine two text search queries to look for overlap. All of the parameter rules remain fundamentally the same as with individual text search and coding queries, but in compound queries you get to refine your search with proximity modifiers, i.e. by looking for only those references that occur near, with, or not with or near, another set of references.
SAVING QUERIES

If you want query results to be available to you again in the future, you can click the box located at the top of any query dialogue box. This will save the query under the Queries section in the navigation view.

You can save queries under Nodes or Sets by clicking the Store Query Results button under the Query tab and following the instructions in the dialogue box, which will look like this:

You can also prepare a query for saving before it is run. When you begin a new query, select the Query Options tab in the dialogue box and specify how you want to save the query. If you choose Preview Only, the results will be discarded when you close the query results in detail view, even if you have saved the project.

If you choose to create a node or set rather than merge the results with an existing node or set, this will show up in the Results folder, which can be found under Queries in the Navigation View sidebar. Note that you cannot code new content at a node created through a query until it has been added to your other nodes by cutting and pasting the node from the Results folder to an appropriate location in your node hierarchy.
Exercise

Take fifteen minutes and run a series of coding queries (or if you’re feeling brave, try a compound query) examine the results and then discard them. Try using the Spread Coding options under the Query Options tab and see what this does to your results views.

When you have created a useful query, save the results under a node in the Results folder. Then, add this node to your node hierarchy.
There are a number of ways to link data in your NVivo project to the ideas and bits of writing that emerge while doing your analysis. Memos and annotations provide ways to create new, searchable and codeable text that can contain ideas about how data should be used, analytical insights, notes to research team members, or reminders about research tasks still to be done. See also links allow you to connect related sources between one another within the project, and hyperlinking allows you to connect to web-based information. Linking in some instances may be preferable to coding, especially where ideas connecting these pieces of data are in formative stages.

All links are stored under Collections in the Navigation View sidebar.

**MEMOS**

A memo is basically a document source that holds some conceptual thinking rather than data. You can create a memo under the Create tab or import one from a supported document format. You can then link the memo to a single source or node, or specific content within these, under the Analyze tab by selecting Memo Link and selecting Link to Existing Memo. You can only link a memo to one piece of data at a time.

Selecting Link to New Memo will create a new memo and automatically link it to the selected source or node. Memo links can later be deleted by selecting Delete Memo Link.

You can also create a memo containing general thoughts and leave it unlinked. Memos are stored under Sources in the Memos folder, and they can be viewed, searched, coded, and classified just like any other document source.

*Exercise*

Create a memo and link it to a source or node. Then, go to that source or node and open up the memo link.

**ANNOTATIONS**

Like memos, annotations serve to record some thinking about a piece of data. Annotations are created within a source by highlighting the relevant section of the source with the mouse arrow and selecting New Annotation under the Analyze tab. Any piece of data that can be coded can also be annotated. You can annotate text sources as well as pdfs, images, and audio and video sources. You can add annotations within a source as many times as you like.
Once you have created an annotation, it will appear whenever you open that source in a window below the detail view. If you code the annotated passage to a node, the annotation window will also appear when you open the node in detail view.

You can hide annotations from Detail View by unchecking the box under the View tab.

You can delete also delete annotations from directly from the Detail View. Alternately, you can delete them by highlighting the annotated text and selecting Delete Annotation under the Analyze tab; or delete them from the Annotations folder.

SEE ALSO LINKS

See Also Links connect related material within your project. They can be used to connect sources, nodes, and specific content within those. They can also be used to create new sources that are automatically linked to the selected content. To create a See Also Link, highlight the relevant section of source data and click See Also Link under the Analyze tab. As with annotations, a See Also Link can be created for any data that can be coded.

Exercise

By now you should have some familiarity with the program and the help system. Using the help system, figure out how to create a See Also Link between specific content (rather than the entire content) within two sources in your project.
**HYPERLINKING**

If you want to connect your data to web-based sources, NVivo provides a hyperlinking function. To add a hyperlink, you must first be in edit mode. Then, simply highlight the selected text, click **Hyperlink** under the **Analyze** tab, and insert the URL. You can also hyperlink to a file path within your computer. Note that hyperlinks can only be added to text sources.

**FRAMEWORK MATRICES**

Framework matrices allow you to summarise large volumes of information across cases and themes, so that you can create an overview of the content of your materials and look at the differences between individuals, organisations or other units of analysis. A typical framework matrix would look like the one illustrated below, with rows for case nodes and columns for thematic nodes:

<table>
<thead>
<tr>
<th></th>
<th>Theme A</th>
<th>Theme B</th>
<th>Theme C</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Case 1</strong></td>
<td>Summary</td>
<td>Summary</td>
<td>Summary</td>
</tr>
<tr>
<td><strong>Case 2</strong></td>
<td>Summary</td>
<td>Summary</td>
<td>Summary</td>
</tr>
<tr>
<td><strong>Case 3</strong></td>
<td>Summary</td>
<td>Summary</td>
<td>Summary</td>
</tr>
</tbody>
</table>

To create a framework matrix, select the option **Framework Matrix**, under the **Create** tab. Name your matrix in the dialog box that opens. Under **Rows**, select the cases that you would like to include as rows in your matrix. Under **Columns**, select the thematic nodes you would like to display as columns. Optionally, under **Row Header Attributes** you can select characteristics of your case nodes (e.g. age, gender etc.), which will be included in the matrix.

**Exercise**

Create a framework matrix for 3 people nodes and 3 thematic nodes of your project. Type your coding summaries directly in the matrix.
IMPORTING REFERENCE LIBRARIES

You can add your bibliographic data to your project, which will make it subsequently searchable. For example, if you have a large EndNote, Zotero or Refworks library with lots of linked files, notes, or URLs, bringing these into your project is relatively easy and gives you the ability to analyze your literature alongside your data.

To import a library, click on the From Other Sources button under the External Data tab and select the appropriate software package from the drop-down menu.

Select the appropriate file and follow the instructions, referring to the help sections if you get stuck. Once you have successfully imported your library, each reference will appear as a new External source.

You can also elect to have attached files added as project internal sources; to have URLs imported along with the reference as external files; and to have any information entered under the “Notes” sections of your library included as new memos in your NVivo project.

Each type of source you import will also create a source classification and attributes. Classifications are examined in the next section.

Exercise

Export the prepared EndNote library file in .xml format and import bibliographic data into your project. Examine the new internals and externals that you have created.

If you make future amendments or additions to your reference library, not to worry. Just repeat the steps above, and NVivo will recognize pre-existing references, amended references, and new references, and process each accordingly. The changes you make should be updated without duplicating references or files.
OTHER AREAS OF INTEREST NOT COVERED IN THE WORKSHOP

As noted at the outset, this has been an introductory workshop to a very large program. Below are some signposts to intermediate functions that you can explore after the workshop if you wish.

PREPARING SURVEY RESULTS AND OTHER DATASETS

You can import datasets including survey results and demographic information in much the way you would import classification sheets. NVivo provides a number of avenues for analysing datasets. You can filter, sort and auto-code dataset content (including analysis by demographic fields), code text fields to nodes, and link these results to the rest of your project. While the workshop will not deal directly with dataset creation or importation, it is worth knowing that this function exists if you are working with datasets in your research.

Keep in mind that NVivo is not designed for sophisticated analysis of dataset results such as regression testing, and you cannot produce tables or graphs from your dataset. You also cannot edit your dataset once it has been imported into NVivo.

RELATIONSHIPS

You can define relationships linking different components of your project. This function is found under Nodes and is a form of node coding. These can remind you and your project team that certain participants know one another, are related, work together, and so on. They can also chart things like birthplace, timelines within the research or regarding events discussed in the project, and organizational relationships as well.

MODELS

You can create visual representations of various aspects of your project. These might include relationships, coding structures, and many other dynamic aspects of your analysis. You can also build static models from scratch using the relatively simple and user-friendly modelling tools. Once you have made a model, you can export it for use in other programs.

While the models generated in NVivo can look like social networks, neither the relationship nodes nor the modelling features are a substitute for Social Network Analysis (SNA) software.

NVIVO REPORTS AND METHODOLOGICAL TRANSPARENCY

NVivo offers Reports functions, which can create automatic outputs charting your coding activities, node structure, classifications, as in the example of the codebook we created in session 2. These reports can be generated at the click of a button, or you can specify parameters for your reports if you want to look at specific bits of work or the activity of specific team members. For some (but not all) qualitative social scientists, it will be important to be able to provide an account of how you did your analysis and arrived at your conclusions. Reports can be helpful to this end. You can also review this article by Bringer et al (2004), which is an early examination of the ways in which NVivo-based analysis can be articulated to others for transparency purposes.
Overview

Session 1 – Importing and organising data

• What can NVivo do for you?
• Importing data
• Organising data
• Working with reference libraries
• Customising your interface
• Terminology
• Questions

Session 2 – Analysing data

• Doing analysis for themes
• Coding at thematic nodes
• Querying data based on coding and classifications
• Other functionality
• Questions

With thanks to Daniel Villar-Onrubia for having contributed to the initial versions of this presentation, especially for the background images.
NVivo is a Computer Assisted/Aided Qualitative Data Analysis (CAQDAS) software package.

‘... helps people to manage, shape and make sense of unstructured information. It doesn't do the thinking for you; it provides a workspace and tools to enable you to easily work through your information.’
(QSRinternational.com)
DATA SOURCES

Online data (e.g. Twitter, Facebook, webs, etc.)

References

Video files

Focus groups / debates

Audio files

Interviews

Pictures

Memos (i.e. your own thoughts)
HOW CAN YOU ORGANISE YOUR DATA SOURCES?
'Nodes are containers for your coding—they let you gather related material in one place so that you can look for emerging patterns and ideas.'

QSR International 2013
HOW CAN YOU EXPLORE YOUR DATA AFTER CODING AT CASE NODES?

You may retrieve all the data relating to a specific person or a certain topic in your study.

- Economy
- Gordon Brown
HOW CAN YOU EXPLORE YOUR DATA AFTER CODING AT THEMES?

You may search for content by one informant on a particular issue.

NODE CLASSIFICATIONS (PEOPLE)
HOW CAN YOU EXPLORE YOUR DATA AFTER USING NODE CLASSIFICATIONS?

You may narrow down queries using attributes (e.g. age, sex, status, etc.)

HOW CAN YOU EXPLORE YOUR DATA AFTER USING NODE CLASSIFICATIONS?

You may retrieve content by people in a certain group on one particular issue.
**KEY ELEMENTS**

- **Folders**
- **Sources**
- **Nodes**
  - Descriptive case nodes
  - Thematic nodes
- **Node classifications**

**THE NVIVO WORKSPACE**

- **List View:** displays content of folders
- **Detail View:** shows the sources
- **Navigation View**

**Election Q&A: Gordon Brown**

"My guilt is pleasure? Online shopping"
RIBBON TABS

Navigation and editing functionalities.

Creating documents, nodes and classifications.

Importing external files and exporting project items.

Coding functionalities, memos, annotations and links.

HELP SYSTEM

Introducing NVivo

What's new in NVivo 10?

Set up and running

Analyze your source material

Other resources

Join the NVivo community
Exercises

1. Creating a new project
2. Importing sources
3. Link to external sources
4. Creating ‘people nodes’
5. Visual markers
6. Coding at ‘people nodes’
7. Auto-coding at ‘people nodes’
8. Creating node classifications
9. Importing classification sheets
10. Importing reference libraries
11. Customising the interface
12. Back-up your project

1. CREATING A NEW PROJECT

- Open NVivo and click on the ‘New Project’ button.
- Leave the ‘Log Project Events’ button unchecked, (it’s normally used for team research projects).
- Name your project, e.g. Politics.
2. IMPORTING SOURCES

• Import research materials included in the Data Sources folder on your H: drive:
  – External Data → Documents → Browse
  – OR you can drag-and-drop materials in the ‘List View’ area

• Create 4 folders to group your materials under ‘Internals’: Debates, Interviews, Images and Videos:
  – Right-click on Internals → New Folder

2. IMPORTING SOURCES

• Importing Twitter content as dataset:
  – Check the NCapture add-on (available in Chrome and Explorer) is enabled on your browser (you may need to authorise the process).
  – Access the materials you would like to import and use the NCapture button on your browser (usually found on the upper right hand side) to capture it.

  To import in your NVivo project:
  – External Data → From Other Sources → From NCapture → Browse

• You can do the same for webpages, Facebook wall posts and comments, and LinkedIn group discussions.
3. LINK TO EXTERNAL SOURCES

• Link the online videos of the debates to your project as external sources:
  Create → New External → ‘External’ tab → Type (Web link)

• You can find the URLs in the ‘Video websites’ doc. file in your H:drive.

• *Work in pairs!*

4. CREATING PEOPLE NODES

• Create a node for one of the speakers in the debate files:
  – Under Nodes create a new folder named ‘People’
  – Select the folder ‘People’ → Create → Node → Name your node:
    ‘Gordon Brown’
5. VISUAL MARKERS OF NODE CODING

• Visualise your nodes using coding stripes:
  View → Coding stripes → Select the nodes you would like to visualise

• Highlight content that has been coded:
  View → Highlight → Select the nodes you would like to visualise

6. CODING AT PEOPLE NODES: WORD DOCUMENTS

• Under the folder ‘Debates’ in your Sources, open the file ‘1st Debate Opening Statements’ (Word file) and code the content at ‘Gordon Brown’:

  Select the text → Right-click → Code selection at existing node
6. CODING AT PEOPLE NODES:
PDF FILES

• Open the ‘Gordon Brown interview’ (.pdf file) and code part of the text included in that source:

  Select the text → Right-click → Code selection at existing node

• You can also code the picture included in the ‘Gordon Brown interview (.pdf file), under the same people node:

  Home → PDF selection: Region → Right-click → Code selection at existing node

6. CODING AT PEOPLE NODES:
IMAGE FILES

• However, to code the image included in the ‘Final Debate Image’, the process will be slightly different:

  Select in list view → Right-click → Code at existing node

• Now, look at the results under the Gordon Brown node.
6. CODING AT PEOPLE NODES: VIDEO FILES

- Using the supplied video file, code a section of the waveform to a thematic node following the same steps as when coding text.

- Use the timeline to select a fragment (hold and drag up to the point you want to code).

- Right-click selected part and choose Code Selection → At existing node

7. AUTOCODING AT PEOPLE NODES

- We can also use heading styles to automatically code text at the rest of the speakers nodes in the ‘1st Opening Debate statements’:
  - Select names/nodes → Home → Edit → Styles → Heading style 2
  - Make sure you apply the same heading style (although it might appear differently…).

  → Important to remove the colon after the names!

- After preparing the transcript, select this in ‘List View’ and click:
  - Analyse → Auto Code → Under EXISTING folder: People
7. AUTOCODING AT PEOPLE NODES

- The styles have already been applied to the 2\textsuperscript{nd} and Final Opening statements, so you can start auto-coding directly.

- Select the 2\textsuperscript{nd} and Final Opening statements in ‘List View’, and click:
  - Analyse → Auto Code → Under EXISTING folder: People

- \textit{Work in pairs!}

8. CREATING NODE CLASSIFICATIONS

- Create a node classification called ‘Speaker Demographics.’
  ‘Create’ tab → Node classification

- Add the attributes
  Right-click on the classification → New attribute

- Assign the classification to the relevant nodes.
  Right-click on the node/s → Classification: Speaker Demographics
9. IMPORTING CLASSIFICATION SHEETS

- Open the *Speaker Demographics* file using Excel and check the data. Close the file.
- Import the classification sheet into NVivo.
  - Step 1: From the External Data ribbon tab choose Classification Sheets.
  - Step 2: Browse and select the file Speaker Demographics in the H: Drive.
  - Step 3: Select classification type: Node classification. Tick the three boxes.
  - Step 4: Click on Node represented as Names and select the location People.
  - Step 5: Finish.

10. IMPORTING REFERENCE LIBRARIES

- Open the EndNote library file (i.e. PM Debate library).
- Select all 6 references (note some have a pdf attached).
- Export these from Endnote in .xml format.
  
  File → Export → Save as type: xml → Save

- Now go back to NVivo and import the bibliographic data into your project.
  
  External data tab → From other sources → From Endnote

- Examine the new internals and externals that you have created.
- Also look at Source Classifications.
11. CUSTOMISING THE INTERFACE

• Take a couple of minutes to customise the interface.
  View → Detail view → Right/bottom
  Dock all/Undock all

• Experiment with changes to:
  o the ribbon guide,
  o sidebars,
  o and docking windows.

• This should enhance your experience of analysis.

12. BACK-UP YOUR PROJECT

• You can keep back-up copies of your NVivo project:
  File → Manage → Copy project → Select location and click OK

• Also explore Project properties under the File tab.
Summary and terminology

- **Sources**: any research materials connected to your NVivo project (transcripts, field notes, videos, audio recordings, images, online materials, as well as academic articles, research plans and notes).
- **External** sources: data not suitable for importing, such as books, entire websites, etc.
- **Nodes**: ‘containers’ in which wholes or parts of sources are kept for analysis.
- **Visual** and **audio** sources can be coded in a similar way to textual data.
- **Classifications**: a way of arranging and rearranging sources and nodes for analysis.
  - **Node classifications** provide a similar function for nodes, and node classification attributes allow more complex queries. Especially relevant to nodes representing actors (i.e. people or organisations).
  - **Also, source classifications** allow the researcher to organise their data sources by type.
- **Attributes**: ways of subdividing and refining classifications by adding numeric or text values to a classified source or node.
- You can import **reference libraries** from a number of different software programmes (e.g. Endnote etc.) and link your references to your data.

References

Before Session 2

• Revise the concepts and functions covered in the first session by watching some of the videos available at: https://www.youtube.com/user/qsrinternational

• Repeat the same exercises we did during the first session using your own data.

Questions: chrysanthi.pap@gmail.com
Overview

Session 2 – Analysing data

- Recap from previous session
- Doing analysis
- Coding at thematic nodes
- Querying data based on coding and classifications
- Memos, annotations and links
- Other functionality
- Questions
Terminology

- **Sources**: any research materials connected to your NVivo project (transcripts, field notes, videos, audio recordings, images, etc.).
- **Internals**: sources imported into your NVivo project.
- **Externals**: sources not suitable for importing (books, entire websites).
- **Nodes**: ‘containers’ in which wholes or parts of sources are kept.
- **Classifications**: a way of arranging and rearranging sources and nodes.
  - **Source classifications**: organise data sources by type.
  - **Node classifications**: organise descriptive node characteristics to allow more complex queries.
  - **Attributes**: ways of subdividing and refining classifications by adding numeric or text values to a classified source or node.
Doing analysis - I

• When to do data analysis?
  o Iteratively, when data generation begins.
  o NVivo is embedded within the entire cycle of qualitative enquiry: building a database, logs and auditing, exploratory searches, coding and linking to references.

• What is the analysis for?
  o Course assignment, dissertation, thesis.
  o To inform policy, produce theory, answer hypotheses.
  o Although basic software functions remain the same for most types of data analysis, in some cases certain tools will be more useful than others.
Doing analysis - II

- How to do data analysis?
  - Deductive mode → Provisional list of codes deriving from research questions, theoretical framework, hypotheses and key variables.
  - Inductive mode → Codes deriving directly from the data.
- In vivo codes.
- Memos, annotations and links.
- Defining codes.

The aim is to ‘understand the patterns, the recurrences, the plausible whys’ (Miles and Huberman 1994, p.69).

Doing analysis - III

‘Codes are tags and labels for assigning units of meaning to the descriptive or inferential information compiled during a study’ (Miles and Huberman 1994, p.56)

- Depending on level of abstraction:
  - Descriptive codes
  - Topic codes
  - Analytical codes

‘Coding should always be for a purpose. It is never an end in itself.’ (Richards 2009, p. 95)
Running queries

- **Word frequency** queries identify the most frequently occurring words (or sets of similar words around a concept).
- **Text search** queries identify all references to a word or phrase, also looking for similar words (useful for quick coding).
- **Coding** queries look for content coded at selected nodes, a combination of nodes, or a combination of nodes and attributes.
- **Compound** queries combine text search and coding queries, text searches where one term precedes the other or two coding queries when content coded at one node is near content coded at another.
## Exercises

1. Parent and child nodes  
2. Coding  
3. Merging nodes  
4. Creating a codebook  
5. Word frequency queries  
6. Text searches  
7. Simple coding queries  
8. Advanced coding queries  
9. Saving queries  
10. Memos and annotations  
11. See also Links  
12. Framework matrices  
13. Matrix coding

### 1. PARENT AND CHILD NODES

- Create at least two new nodes based on themes you have found in the Prime Ministerial Debates (or, if using your own data, create nodes for coding that):  
  Create → Node → Name your nodes (i.e. economy or threats)

- Under one of your new nodes, create two child nodes as well:  
  Right-click on node (e.g. economy) → New node → Name child node
We will now spend a few minutes coding the material in the debates and interviews.

- Coding at existing nodes:
  1. Select the text → Analyse tab → Code selection at existing nodes
  2. Right-click selected text and choose Code Selection → At existing node
  3. Select the text → Drag and drop

*Code different types of sources: Word, pdf and images!*

- Coding at new nodes:
  Select the text → Analyse tab → Code selection at new node

- Coding ‘in vivo’:
  Select the text → Analyse tab → Code in vivo

- Uncoding:
  Select the text → Analyse tab → Uncode selection
  OR use the coding stripes.

- You can also experiment with the ‘Quick Coding’ bar.
3. MERGING NODES

- Right-click on node to be merged → Select: Cut
- Right-click on node you would like the previous one to be merged with → Select: Merge into selected node
- Click OK

- You can also copy a node and merge with another node, without losing the original node.

4. CREATING A CODEBOOK - I

- The codebook can help you have a record of node definitions you can look at while coding.

- Before creating the codebook, you would need to add definitions to the nodes you would like to include in the report.

- Open your thematic nodes in ‘List View’ and then:
  - Right-click on each of the nodes you would like to define
  - Choose Node properties
  - Add a definition to the ‘Description’ box
4. CREATING A CODEBOOK - II

To create the codebook:

• Step 1: Under the Explore tab → New report: via Wizard
• Step 2: Select the option From a View: Node
• Step 3: Expand the submenu under Node
• Step 4: Choose Name and Description fields and move to right column
• Step 5: Continue without changing anything else
• Step 6: Name your report: Codebook
• Step 7: Click Finish

5. WORD FREQUENCY SEARCHES

• Run a word frequency query for your project:
  Query tab → Word Frequency → Set parameters → Click Run

• Examine the Word Cloud, Tree Map, and Cluster Analysis on the right hand side of your screen.

• Re-try your research, but eliminate shorter words or move the Finding Matches bar from ‘Exact’ to ‘Similar’. What happens?

• Work in pairs!
6. TEXT SEARCHES

• Run a text search query and examine the results:
  Query tab ➔ Text search ➔ Insert text ➔ Click Run

• Try using the Special instructions button on the right to narrow your search:
  – Asterisk (*) as a substitute for zero or more characters.
    For example—g*t will find get, great and gt
  – Question mark (?) as a substitute for a single character.
    For example—g?t will find get and got but not great or grunt
  – You can use Boolean operators AND, OR, NOT or + (required)
  – Fuzzy search: 'color~' will find 'colors' or 'colour'
  – Specify proximity: “happy busy”~10

7. SIMPLE CODING QUERIES

• Using a simple coding query, find all of the text from the debate opening statements made by people between 50-59 years old.
  Query tab ➔ Coding ➔ On the Simple tab choose Any Node Where and click on Select ➔ Expand the Speaker Demographics sub-menu and click on Age Range ➔ Set appropriate values ➔ Click Run

50-59
8. ADVANCED CODING QUERIES

- Using an *advanced* coding query, find all of the quotes on economy from people between 50-59 years old.

Query tab → Coding → On the Advanced tab leave selected: Coded at – All selected Nodes – and click Select → Choose the node Economy and click OK → Click on Add to List

Then, select Coded at – Any Node Where – and click Select → Expand the Speaker Demographics sub-menu and click on Age Range → Set appropriate values and click OK → Click on Add to List

Click Run

9. SAVING QUERIES

- Run a series of coding queries, examine the results and then discard them.
- Try using the ‘Spread Coding’ options under the Query Options tab and see what this does to your results views.
- When you have created a useful query, use the Query Options tab to save the results under a node in the Results folder.
- Try to save the query to project by ticking the Add to query box on the upper left hand side of the window.
10. MEMOS AND ANNOTATIONS

- Create a memo and link it to a source or node:
  Create tab → Memo
  Analyse tab → Memo link → Link to existing memo and choose from list

- Then, go to that source or node and open the memo link:
  Analyse tab → Memo link → Open linked memo

- Follow the same process for annotations, or:
  Right-click on selected text → Links → Annotation → New annotation

11. SEE ALSO LINKS - I

- By now you should have some familiarity with the program and the help system.

- **Work in pairs** using the help system, to figure out how to create a See Also Link between specific content (rather than the entire content) within two sources in your project.
11. SEE ALSO LINKS - II

- Linking content between sources:
  Select text from source 1 → Home → Copy
  Select text from source 2 → Home → Paste as See also Link

- See also Links appear at the bottom of the detail view.

12. FRAMEWORK MATRICES

- Step 1: Create tab → Click Framework matrix.
- Step 2: Name your matrix in the dialog box that opens.
- Step 3: Under Rows, select 3 people nodes.
- Step 4: Under Columns, select 3 thematic nodes.

You can auto-summarise Framework matrix content using the Analyse ribbon tab.
13. MATRIX CODING

- Step 1: Query tab → Select Matrix Coding.
- Step 2: From the Rows tab → Next to Selected Items → Click Select and choose the nodes you would like to display as rows → Add to List
- Step 3: From the Columns tab → Next to Selected Items → Click Select and choose the nodes you would like to display as columns → Add to List
- Step 4: Click Run

Summary

- You can create coding hierarchies by using parent and child nodes.
- A codebook can help with defining your nodes.
- You can perform a number of different queries on your data:
  - Word frequency (Tag Cloud, Tree Map, and Cluster Analysis)
  - Text searches
  - Coding queries
  - Compound queries
- Memos are used to hold conceptual thinking on the data. Annotations are more commonly used to record clarifications or other contextual information.
- See also Links allows you to create connections between two different sources, between content belonging to two different sources, or between a whole source and content included in a different source.
- Framework matrices and matrix coding allow you to create a summary overview of your data.
Additional resources

• Company website for more information:  
  http://www.qsrinternational.com
• Youtube tutorials on Nvivo:  
  http://www.youtube.com/user/QSRIInternational
• Practical support, training and information:  
  http://caqdas.soc.surrey.ac.uk
• Learning qualitative data analysis on the web:  
  http://onlineqda.hud.ac.uk
• Guidelines on managing and documenting qualitative data:  
  http://www.data-archive.ac.uk

References