Databases: User-friendly databases using Access
How to Use This Course Book

This handbook accompanies the taught session for the course. Each section contains a brief overview of a topic for your reference and then one or more exercises.

The Exercises

Exercises are arranged as follows:
- A title and brief overview of the tasks to be carried out
- A numbered set of tasks, together with a brief description of each
- A numbered set of detailed steps that will achieve each task

Your lecturer will direct you to the location of files that are needed for the exercises. If you have any problems with the text or the exercises, please ask the lecturer or one of the demonstrators for help.

This book includes plenty of exercise activities – more than can usually be completed during the hands-on sessions of the course. You should select some to try during the course, while the teacher and demonstrator(s) are around to guide you. Later, you may attend follow-up Course Clinics, where you can continue work on the exercises, with some support from IT teachers. Other exercises are for you to try on your own, as a reminder or an extension of the work done during the course.

Writing Conventions

A number of conventions are used to help you to be clear about what you need to do in each step of a task.

In general, the word press indicates you need to press a key on the keyboard. Click, choose or select refer to using the mouse and clicking on items on the screen (unless you have your own favourite way of operating screen features).

Names of keys on the keyboard, for example the Enter (or Return) key, are shown like this ENTER.

Multiple key names linked by a + (for example, CTRL+Z) indicate that the first key should be held down while the remaining keys are pressed; all keys can then be released together.

Words and commands typed in by the user are shown like this.

Labels and titles on the screen are shown like this.

A button to be clicked will look like this.

The names of software packages are identified like this, and the names of files to be used like this.
Software Used

*Access 2013

*Windows

Files Used

- Inventory.accdb
- Pendleton Products.accdb
- Woodstock Road Dentist.accdb

Revision Information

<table>
<thead>
<tr>
<th>Version</th>
<th>Date</th>
<th>Author</th>
<th>Changes made</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.0</td>
<td>August 2014</td>
<td>Pamela Stanworth</td>
<td>Created</td>
</tr>
<tr>
<td>1.1</td>
<td>January 2015</td>
<td>Pamela Stanworth</td>
<td>Small edits</td>
</tr>
<tr>
<td>2.0</td>
<td>August 2015</td>
<td>Pamela Stanworth</td>
<td>Revised for Access 2013</td>
</tr>
</tbody>
</table>

Copyright

Pamela Stanworth makes this document and the accompanying PowerPoint presentation available under a Creative Commons licence: Attribution-NonCommercial-ShareAlike CC BY-NC-SA. pamela.stanworth@it.ox.ac.uk

Screenshots in this document are copyright of Microsoft.

The Oxford University crest and logo and IT Services logo are copyright of Oxford University and may only be used by Oxford University members in accordance with the University’s branding guidelines.
Contents

1 Introduction ................................................................................................. 1
  1.1 What You Should Already Know .......................................................... 1
  1.2 What You Will Learn ............................................................................ 1
  1.3 What is Access? .................................................................................... 1
  1.4 Where Can I Get a Copy? ................................................................. 2
  1.5 Using Office 2013 ............................................................................ 2
  1.6 Using the Database Files for IT Learning Programme Exercises – Access 2013 ........................................................................ 3

2 Getting Started ......................................................................................... 4
  2.1 Some Database Vocabulary ................................................................. 4
  2.2 App or Desktop Database? ................................................................. 4
  2.3 Using the Database Files for ITLP Exercises – Access 2013................. 4
  2.4 Working on Data Using Forms ........................................................... 4

3 Creating a Form Using the Wizard ............................................................... 6
  3.1 Using the Wizard to Create a Form Based on a Table ........................ 6
  3.2 Naming Forms and Other Objects in a Database ............................... 7
  3.3 Using the Form .................................................................................. 7
  3.4 Managing Forms ................................................................................. 8
  3.5 Switching Between Views of a Form ................................................. 8

4 Building a Form in Design View ................................................................. 10
  4.1 Creating a Blank Form ...................................................................... 10
  4.2 Showing and Hiding Features in Design View ................................... 10

5 Objects on a Form (Working in Design View) ................................................ 11
  5.1 Adding a Graphic Object ................................................................... 11
  5.2 Manipulating Graphic Objects ........................................................... 11
  5.3 Moving and Resizing Form Objects ................................................... 12
  5.4 Adding a Field Control ....................................................................... 12
  5.5 Deleting a Control on a Form ............................................................ 13
  5.6 Manipulating a Field Control and its Label ....................................... 14
  5.7 Editing Labels .................................................................................... 14
  5.8 Multiple Selection on a Form ............................................................ 15
  5.9 Arranging Several Objects on a Form ............................................... 15

6 Formats and Properties of Form Objects .................................................. 17
  6.1 Themes on a Form ............................................................................. 17
6.2 Using Buttons for Formatting Controls and Labels.......................... 17
6.3 Data Formats in a Form Control .................................................... 18
6.4 Property Sheet ............................................................................... 18
6.5 Form Properties ............................................................................. 19
6.6 Changing the Record Source of a Form ......................................... 20

7 Adding Other Types of Control .................................................... 21
7.1 Useful Objects ............................................................................... 21
7.2 Special Controls Created Automatically ....................................... 21
7.3 Adding an Option Group (Optional) ............................................. 21
7.4 Using the Option Group in Form View ......................................... 22
7.5 Adding A Combo Box .................................................................. 22
7.6 Using the Combo Box in Form View ............................................ 23
7.7 Importance of Combo Box for Related Join Data ....................... 23
7.8 List Box ....................................................................................... 23
7.9 A Combo Box For Finding A Record – Optional ............................ 23
7.10 Editing a Combo Box or List Box ............................................... 24

Exercise 9: Adding and managing combo boxes ............................. 25
7.11 Pictures on a Form (Optional) ................................................... 25
7.12 Adding a Chart on a Form ......................................................... 25

8 Form Structure ............................................................................. 26
8.1 Sections, Headers and Footers ..................................................... 26
8.2 Tab Order ..................................................................................... 26
8.3 Tabbed Pages On A Form ............................................................. 27
8.4 A Form Showing Multiple Records ............................................ 27
8.5 Working With Layouts on a Form ................................................. 28

9 Subforms ...................................................................................... 29
9.1 Creating a Subform On a Form .................................................... 29
9.2 Using the Subform On the Form .................................................. 30
Exercise 12: Creating and using a subform .................................... 31
9.3 Modifying a Subform On the Main Form .................................... 31
9.4 Opening a Subform for Editing .................................................... 32

10 User Interface ............................................................................ 33

11 Command Buttons ...................................................................... 34
11.1 Command Buttons in a form ..................................................... 34
11.2 Creating a Command Button .................................................... 34
11.3 Changing the Appearance of a Button ............................................. 36

12 Macros .............................................................................................. 37

12.1 Using Macros in an Access Application ........................................ 37
12.2 Building a Simple Macro ............................................................... 37
12.3 Running a Macro From the Navigation Pane ................................... 39
12.4 More Commands for a Macro ......................................................... 39
12.5 A Macro That is Run Using a Button ............................................. 40
12.6 Attaching a Macro to A Form or Report (Optional) ......................... 40
12.7 A Macro That Runs When the Database Starts .............................. 42

13 A Navigation Form ................................................................ 43

13.1 Creating a Navigation Form ............................................................. 43
13.2 Changing the Appearance of the Navigation Buttons .................... 44
13.3 Changing the Text on a Navigation Form ....................................... 45
13.4 Using a Navigation Form ................................................................. 45

14 A Startup Form ..................................................................... 47

14.1 Creating a Startup Form ................................................................. 47
14.2 Compacting the Database ............................................................. 48
14.3 Over-riding the Startup Options .................................................... 48
14.4 Publishing the Finished Database For Users ................................. 48

15 What Next? ........................................................................... 49

15.1 Downloadable Course Materials and More – the ITLP Portfolio .... 49
15.2 Database Courses Which Precede This ......................................... 49
15.3 Database Courses Which May Follow This .................................. 49
15.4 Course Clinics ................................................................................. 49
15.5 IT Services Help Centre ................................................................. 49

Appendix 1: Viruses and Security Levels in Access .................................. 50

Why Worry About Viruses? ................................................................. 50
Scanning for Viruses ........................................................................... 50
Access 2013 and Virus Security .......................................................... 50
Further Help with Security and Trust Center Settings ..................... 54

Appendix 2: Student Exercises ..................................................... 55
1 Introduction

Welcome to the course “Databases: User-friendly databases using Access”.

This handbook accompanies the course delivered by Oxford University IT Services, IT Learning Programme. Although the exercises are clearly explained so that you can work through them yourselves, you will find that it will help if you also attend the taught session where you can get advice from the teachers, demonstrators and even each other!

If at any time you are not clear about any aspect of the course, please make sure you ask your teacher or demonstrator for some help. If you are away from the class, you can get help by email from your teacher or from help@it.ox.ac.uk

1.1 What You Should Already Know

This session is one of a series that cover the important aspects of building and managing a database, using Microsoft Access as an example.

We will assume that you have already attended the course “Databases: Building a database using Access” (or equivalent), and that you are familiar with creating tables with suitable fields, and running forms, queries and reports that have already been created.

You do not need to know anything about creating a form or report.

The computer network in our teaching rooms may differ slightly from that which you are used to in your College or Department; if you are confused by the differences, ask for help from the teacher or demonstrators.

1.2 What You Will Learn

In this session we will cover the following topics:

- Creating a form using the wizard or from blank
- Simple design changes on forms in Design View
- Adding and arranging controls on a form
- Formats and properties of a form and its controls
- Form layout, including subforms
- Simple macros and command buttons
- Creating a navigation (startup) form

Related Database sessions, should you be interested, are described in Part 15 below.

1.3 What is Access?

Access is database management software. It enables you to build and maintain a database.

Access is part of Microsoft Office (only in the Professional, Ultimate, and Enterprise editions for Windows). Access is not available for Macintosh computers (Mac users may try FileMaker Pro).

An Access database consists of the data held in a number of tables, plus a number of other objects which are used to manage the data. All these are saved together in a single file. In this course, we will focus on forms.
A database application may be built using forms, menus, control buttons and program code that respond to events.

1.4 Where Can I Get a Copy?

If you have a copy of *Microsoft Office Professional*, then you already have a copy of *Access*. If you are unable to find it on your computer, it may not have been installed and you should talk to your IT support contact (or the IT Services Help Desk).

If you are a member of staff, you can obtain a copy of *Microsoft Office Professional* from the Online Shop. Students can occasionally obtain *Microsoft Office* at a reduced cost: read more at the IT Services website.

1.5 Using Office 2013

If you have previously used another version of *Office*, you may find *Office 2013* looks rather unfamiliar. “Office 2010: What’s New” is a self-study guide covering the ribbon, Quick Access Toolbar and so on. This can be downloaded from the ITLP Portfolio at [http://portfolio.it.ox.ac.uk](http://portfolio.it.ox.ac.uk) (look in the *Access* category).

For anyone who prefers not to use a mouse to control software, or who finds a keyboard method more convenient, it is possible to control *Office 2013* applications without using a mouse. Pressing ALT once displays a black box with a letter or character next to each visible item on the ribbon and title bar (shown in Figure 1).

![Figure 1 Keystrokes to Control Ribbon Tabs and Title Bar (Press ALT to show these)](image)

After you have typed one of the letters/characters shown, the relevant ribbon tab or detail appears, with further letters/characters for operating the buttons and controls (shown in Figure 2).
Databases: User-friendly databases using Access

3 IT Learning Programme

Figure 2 Further Keystrokes to Control Buttons

The elements within a dialog can be controlled, as usual with Windows applications, by using TAB to navigate between items or by typing the underlined character shown beside an item.

1.6 Using the Database Files for IT Learning Programme Exercises - Access 2013

Note that Access 2013 only trusts files if they have been saved in a “Trusted Location”. The network drive H:, used for most IT Learning Programme courses, has been designated an Access Trusted Location in our teaching rooms. If you make copies of the files for these exercises, and save them on your own computer in a location that is not trusted, you may not be able to carry out all the activities described.

Appendix 1 discusses the question of virus protection and trusting locations further.
2 Getting Started

2.1 Some Database Vocabulary

A collection of database information is organised into one or more tables. You may think of each table as data laid out in a grid.

Each row of the table is known as a record. There must be one record for each item included in the table – for example, the records may be the employees in a department, the books in a library or the individual wall paintings in an ancient cave. The order of the records is not important: indeed it is often useful to change the order the records are shown in, when analysing the data.

Each column of the table is known as a field. Each field contains a different piece of information about the record items – for example, an employee's date of birth, a book's author or the dimension(s) of a wall painting. All the entries in one column must have the same data type e.g. all text or all integer numbers.

The set of tables, along with the queries, forms and reports used to manipulate them, are saved together in one Access file.

The importance of designing the set of tables correctly, with appropriate fields collected together in tables, and with relationships joining the tables, has been discussed in the course Access: Building a database.

2.2 App or Desktop Database?

Access 2013 can also be used to create an app database: where users work on the data via a web browser. This would require communication using Office 365 or SharePoint 2013, and is not the subject of this course. We will create a desktop database, which is saved locally on your computer or a network drive.

2.3 Using the Database Files for ITLP Exercises – Access 2013

Please note that Access only trusts files if they have been saved in a “Trusted Location”. The network drive H:\, used for most IT Learning Programme courses, has been designated an Access Trusted Location. If you make copies of the files for these exercises, and save them on your own computer in a location that is not trusted, you may not be able to carry out all the activities described.

Appendix 1 discusses the question of virus protection and trusting locations.

2.4 Working on Data Using Forms

The data in a database is stored in tables, and the tables are joined using relationships. This is the structure which is essential for the data to model your situation or project properly. However, a table is not a suitable or efficient environment for people to work on the data: finding the correct row and column, and typing the correct data is difficult and likely to be error-prone.

For this reason, a database must have forms which people use for reviewing and editing the data that is held in tables. A well-designed form is laid out clearly, with the data boxes or controls in a convenient sequence so that the human user can enter and edit the data efficiently. This helps the user to read and edit the data much more easily than by looking at the same information in the table.

Several forms may be based on the same table (or query), but offer different layout or a different set of fields, to be used in different situations. As usual, available forms are listed in the Navigation Pane.
Exercise 1: Opening a database file

Now look at this exercise (page 55).
3 Creating a Form Using the Wizard

In addition to tables, the Navigation Pane also displays a list of any forms that have been created (using the Navigation Pane options menu, make sure that Object Type and All Access Objects are selected).

Forms can make data entry easier for you or other users of the database. A form is used for working on the data that is saved in the tables.

![Image of Navigation Pane listing forms]

Figure 3 The Navigation Pane Listing Forms

3.1 Using the Wizard to Create a Form Based on a Table

An efficient way to generate a form is to use the wizard. Form Wizard is found on the Create tab of the ribbon.

The wizard takes you through the steps to choose the fields, layout, and appearance of the form.
3.2 Naming Forms and Other Objects in a Database

The last step in the wizard is to give a suitable name for the form.

By convention, form names always begin with `frm` (although Access is likely to suggest a name that does not conform with this convention). Similarly, table names begin with `tbl`, query names begin with `qry` and report names begin with `rpt`. These Reddick naming conventions can be found at [http://mvps.org/access/general/gen0012.htm](http://mvps.org/access/general/gen0012.htm).

Although it is possible in Access to include spaces in object names, it is good practice to avoid spaces. This is because when an object name is included in an expression (perhaps in a calculation), then any spaces are difficult for Access to parse and you must remember to enclose the object name in [square brackets] every time. If there are no spaces, then the names of forms, reports etc are not ambiguous, and expressions are easier for Access (and people) to read. This also applies to the names of fields and controls.

Designers may use a mixture of lower case and capital letters, or may use some punctuation symbols to make object names and field name easy to understand. Examples might be `tblStudentApplications` or `frmSimple_Address_List`.

3.3 Using the Form

Form names appear in the Navigation Pane. Double-clicking a form name opens it in Form View, showing one or more records. This is where the user can navigate between the fields and records, and view, edit or add data.
3.4 Managing Forms

When finished, the form can be closed by clicking ×. If the form design has been changed, you will be prompted to save. You are saving changes to the form design, not changes to the stored data (data changes would have been saved automatically as you worked).

Delete any unwanted form by selecting its name in the Navigation Pane, pressing DELETE, and then agreeing to the confirmation dialog.

Exercise 2: Creating a form using the wizard

Now look at this exercise (page 57).

3.5 Switching Between Views of a Form

A form may be displayed in three Views, each having its useful features and its limitations. These are found using the first button at the left end of the Home tab (and also the Form Layout Tools tab when available). The face of this button varies, including , so it can be used to toggle between Form View and Layout View. It is usual to switch frequently between views, while the design is evolving.

If you click on the arrow below the button image, however, you can see a list of Viewing options. You should choose the view based on what you need to do with the form:
Form View is the default view where you edit the data. You cannot change the layout of the form.

Layout View allows you to rearrange and change the appearance of the form. Sample data is visible (so you can get an idea of what the form will look like in Form View) but is not editable. This is a good choice for working on the visual appeal and effectiveness of a form.

Design View allows the most detailed design changes. No data is displayed. This view is good for making detailed choices and settings. This view is covered in chapter 4 below.

Many of the activities discussed in this course can be carried out equally in Layout View or Design View. We will focus on Design View in this chapter. Layout View is used in a later course “Databases: Reporting data using Access”.

Figure 6 Switching Between Views of a Form
4 Building a Form in Design View

Although the Form Wizard offers a quick way to create a form, it does not offer flexibility of design or layout. Working in Design View, you can create a form starting with a blank, in which case you have great flexibility over the design and content of your form.

4.1 Creating a Blank Form

On the Create tab of the ribbon, creates a new blank form in Design View.

![Figure 7 A Blank Form in Design View](image)

The form is displayed in Design View, with gridlines. The working space of the form can be extended by dragging the bottom or right edge.

4.2 Showing and Hiding Features in Design View

Three new tabs of Form Design Tools appear on the ribbon, offering commands which are relevant to this view.

It may be useful to show gridlines over the form, using (from on the Arrange tab). The gridlines will not show when the finished form is used. will display rulers around the form.

Exercise 3: Creating a blank form

Now look at this exercise (page 58).
5 Objects on a Form (Working in Design View)

5.1 Adding a Graphic Object

Simple graphic objects may be used for decoration or to clarify the layout of the form. The **Design** tab on the ribbon (only visible in Design View) includes two buttons for adding graphic objects:

- adds a line at the position marked (dragged) by the mouse
- adds a rectangle at the position marked (dragged) by the mouse

Immediately after a graphic object has been added onto a form, an orange border and handles are shown around it, showing that it is currently selected. If the object is not correct, it is easy to delete it (press DELETE while the object is selected) and try again.

![Figure 8 Adding Lines and Rectangles on a Form](image)

**Figure 8 Adding Lines and Rectangles on a Form**
(A rectangle is shown with selection border & handles)

5.2 Manipulating Graphic Objects

An object on a form can be **selected** by clicking an edge so that an orange border and handles appear around it. Before any object can be changed or manipulated, it must be selected.

A selected object can be **resized** by dragging a handle. As the mouse hovers over a handle, the mouse pointer changes into a two-headed arrow, indicating the directions it can be dragged.
A selected object can be **moved** by dragging its edge (avoiding the handles). As the mouse moves over an edge, the mouse pointer changes into a four-headed arrow. If the object is filled, it can also be moved by dragging anywhere inside it.

### 5.3 Moving and Resizing Form Objects

The two main types of elements on a form are controls and labels. The **controls** are boxes where the user of the form will actually enter data (corresponding to a particular field in a table). In Layout View, these boxes are displayed with sample data inside, which can be a great help when you are planning the appearance of the form.

Most field controls have an associated **label** to inform the user about which information they should give in the control. Additional labels, not connected to any field data, are sometimes used to display a title or other information on the form.

![Figure 9 A Form With Text Controls and Labels](image)

You can select a control or label by clicking on it. An orange border will appear around the object. You can then move the object by dragging and dropping, or resize the object by dragging an edge. A selected object can also be moved around using the arrow keys (up, down, left, right).

### 5.4 Adding a Field Control

Objects on a form are known as **controls**.

A **field control** is commonly one that is bound to a data field from the underlying table. This means that when the form is used, this control will display the value from that field, changing automatically as the user navigates between records.

The Field List can be displayed using **Field List** on the **Design** tab. This lists all the field names available to the form. Initially, all the fields in all the tables in the database are available. The Field List can be moved to a convenient position by dragging its title bar.
A bound field control is created by dragging the desired field name from the Field List onto the form, and dropping it at the required position. When the mouse is let go, a new control is added onto the form, which is automatically bound to the selected field from the table.

![Figure 10 Adding the First Field Control](image)

Further field controls can then be added to the form (the Field List is then re-arranged to emphasise the table that was chosen for the first field control).

![Figure 11 Adding a Second or Later Field Control](image)

5.5 Deleting a Control on a Form

An object or control can be selected, then deleted using the DELETE key. Removing a bound control from a form does not affect the field or the data stored in the underlying table.
If a bound field control is selected and deleted, then its associated label is also deleted. If just the label is selected, it may be deleted while leaving the field control intact.

5.6 Manipulating a Field Control and its Label

When a field control is created, a pair of boxes appear on the form. The part which will display the field data is usually placed on the right. The associated label, which shows the field name and can be edited, is usually on the left.

A field control and its label are generally connected as a pair, so moving one will often also move the other (in Design View).

The orange selection border shows which object is selected, ready for moving or resizing. Dragging different parts of a control will give different effects:

<table>
<thead>
<tr>
<th>What to drag</th>
<th>Mouse pointer shape</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>orange handle</td>
<td>two-headed arrow</td>
<td>resize a box</td>
</tr>
<tr>
<td>an edge or the middle</td>
<td>four-headed arrow</td>
<td>move a box and its associated label</td>
</tr>
<tr>
<td>the bigger handle at top left</td>
<td>four-headed arrow</td>
<td>move a box but not its associated label</td>
</tr>
</tbody>
</table>

Similarly, the label itself can be selected separately, then resized or moved as needed.

Size to Fit is a useful button which resizes a control to fit neatly around its contents (it is found on the Size/Space menu on the Arrange tab).

5.7 Editing Labels

Most data controls have a plain label connected. Additional labels (static text, unrelated to record data) can be added by using .

In the first instance, these labels use the field names (e.g. LastName or Address1) or the caption if one has been defined in the table design.

You may now prefer to modify the text in a label, so that it describes the field more clearly (e.g. “Student’s Surname”, “Address, First Line”).

Clicking the label once will select it (orange handles appear on its edges). Clicking a second time inside the label displays a flashing insertion point. This is used as you would in word-processing: remove text using DELETE or BACKSPACE, then re-type the text. Clicking outside the label object will de-select it, when finished.

Size to Fit is a useful tool for re-sizing a label so that it fits neatly around its text contents: is found on the menu on the Arrange tab.

If you want to completely remove a label from the form, click the label once to select it and then press DELETE. Note that you are deleting the label but not the text box (or other kind of control) where the data is displayed.
Exercise 4: Adding and manipulating field controls on a form

Now look at this exercise (page 59).

5.8 Multiple Selection on a Form

Holding CTRL, while clicking several objects on the form in turn, will select them all as a set. Then they can all be moved or resized together.

Alternatively, using the mouse you can drag a large enclosing rectangle on the form, to select all objects which lie within the rectangle.

Figure 12 Selecting Several Objects on a Form (Hold CTRL key)

5.9 Arranging Several Objects on a Form

Dragging an object to overlap another reveals that one lies behind the other. Access maintains the stacking order of all objects on a form: which ones are in front or behind. The stacking order can be changed by selecting an object, then choosing Bring to Front or Send to Back.
Pairs or sets of objects can be sized, aligned or spread out using the remaining buttons on the menu.

**Exercise 5: Manipulating multiple field controls on a form (Optional)**
You may look at this optional exercise (page 61).
6 Formats and Properties of Form Objects

Most of these changes can be made when working with a form in either Layout View or Design View. Remember that in Layout View some sample data is shown in the controls, to help you with the layout, but you cannot edit the values here.

6.1 Themes on a Form

When you switch to Design View, three new ribbon tabs appear, entitled Form Design Tools. Not surprisingly, the Design tab gives you control over the design of the whole form.

You can easily change the whole look of the form (fonts, colours, borders, etc.) by using the Themes Gallery. Clicking on the Design tab displays a gallery of theme designs. Selecting one of the options will re-format many of the elements on the form.

![Themes Gallery](image)

**Figure 14 Themes Gallery**

6.2 Using Buttons for Formatting Controls and Labels

You can modify the formatting of a control or label using buttons on the ribbon. For each of these, start by selecting the control(s), then click a button.

A variety of popular formats can be applied, by using buttons on the Format tab:

![Popular Formatting Buttons](image)

**Figure 15 Popular Formatting Buttons**
Familiar buttons are used for changing the appearance of text in a selected control, such as **(bold)**, * (italic) and _ (underline).

Drop-down list boxes change the font or font size.

Alignment buttons will change the way text is aligned horizontally within its box. The appearance of any object may be changed using further buttons for colours, border styles etc.

The Paste Formatting button can be used to “pick up” the formatting of one object and “paste” it onto another object.

Improve the colour and appearance of a control using and which includes colours, line thickness etc.

### 6.3 Data Formats in a Form Control

There are some additional options available for individual field controls. If the control displays numerical data, you can change the number format, for example specifying the number of decimal places to display, or displaying the value as a percentage.

![Figure 16 Options for Number Format](image)

Similarly, a variety of formats are available for displaying dates and times. Relevant formats will appear in the number format menu, when a numerical field control is selected.

**Exercise 6: Formatting controls and labels on a form**

Now look at this exercise (page 62).

### 6.4 Property Sheet

The behaviour and appearance of a control can be changed by editing its properties in the Property Sheet.

If the Property Sheet is not visible, clicking on the Design tab will show it.

When an object is selected, its properties are listed in the Property Sheet, and the selected object is named at the top of the sheet, for confirmation.

Overtype the previous value, or choose from a drop-down list if offered.
The Properties are divided using tabs, and they include:

**Format** properties  
some of these properties may have been set using toolbar buttons, see above

**Data** properties  
here a default value and/or validation rule can be set, and the control source is specified  
e.g. **Enabled=**"Yes" means the user can place the focus on a control using the mouse or keyboard;  
**Locked=**"Yes" means the user cannot alter the value set in a control

**Event** properties  
a procedure or macro can be set to take place on a control event, such as when it is clicked or when its value is updated

**Other** properties  
these include whether the control can be reached by pressing Tab, and the text that appears in the status bar or on a screen-tip

### 6.5 Form Properties

The background colour of the form itself can be changed, by clicking the form background then using ✧ to choose a colour.

To select the form as a whole, click the Form Selector: in Design View this is the block at top left where the two rulers meet (and in Layout View it is the bar along the left edge of the form). Another way to select the form as a whole is to use the drop-down at the top of the Property Sheet. The Property Sheet then displays the properties of the form.

Form properties include:

**Caption**  
alternative text, to appear on the title bar in Form View

**Scroll bars**  
display vertical, horizontal, both or neither
Record selectors show or hide them
Dividing lines between Detail and Header/Footer
Min/max buttons enable either or both
Auto center the form is automatically displayed at the centre of the window

... and a range of form events.

6.6 Changing the Record Source of a Form

When a form is created using the wizard, the table nominated becomes the record source of the form: the place where Access will seek values to display in the field controls.

Usually the record source need not be changed. However, if the form is to display values based on a different source, then this property of the form can be changed in the Property Sheet.

If fields are to be drawn from more than one table, this is done by basing the form on a query. So first you create the query, then set the query as the record source, by choosing the query name as the record source property. (Queries will be discussed in another course, see part 15.3 below).

Figure 18 Changing the Record Source of a Form

Exercise 7: Using the Property Sheet

Now look at this exercise (page 64).
7 Adding Other Types of Control

7.1 Useful Objects

The **Design** tab includes buttons for adding useful items such as a title, date and time onto a form. If the form has no header or footer, these are created when you first use one of these buttons.

If there is no title yet, one can be added in the Form Header. A **logo** is simply a static image, included on the form header for decoration or branding. A **label** is a static piece of text, not related to any of the field values.

![Figure 19 Some Useful Objects for Form Design](image)

7.2 Special Controls Created Automatically

In Design View, a field control is typically created by dragging the field name from the Field List and dropping it onto the form.

The data type of each field has already been defined in the Table Design. Some field data types, when added onto a form, automatically create suitable special controls.

For example, dragging a Yes/No field adds a checkbox. If a field already has a lookup set in the table design, then dragging its field name adds a combo box (a drop-down list box). Dragging a long-text type field adds a large text box in which a vertical scroll bar appears when needed.

If a date/time field is dragged onto a form, the field control will offer the user a date picker (calendar) as a convenient way of entering dates.

7.3 Adding an Option Group (*Optional*)

Where the user is to select a value from just a few options, as in a survey for example, an **option group** may be a convenient facility.

An option group is one of the special types of controls available from the Controls gallery (on the **Design** tab). See Figure 19.

A wizard helps you to create it, if you make sure that **Use Control Wizards** is turned on before starting the process. The wizard is started by clicking **Design** then dragging a suitable rectangle on the form.

This wizard takes you through some simple steps. First you must give suitable text (or numbers) for the labels – these are the choices that the user will select from (see Figure 20a). One of the values can be set as the default, so that this value will be assigned unless the user chooses another.
Note that although the user is selecting one from a list of text choices presented on the form, the value actually stored in the table can only be a number. In the wizard you assign a number corresponding to each user choice (see Figure 20b). This is a limitation of using option groups, which is usually acceptable, but if it is not you could consider using a combo box instead, see below.

7.4 Using the Option Group in Form View

The user clicks an option button, toggle button etc to indicate their chosen value. A corresponding integer (1, 2, 3 etc. as set in the wizard) is stored in the table.

Exercise 8: Adding some special field controls

Now look at this exercise (page 66).

7.5 Adding A Combo Box

A combo box helps the user to enter data accurately, as several permissible values are offered in a list, from which the user selects one.

Provided that is switched on (at the bottom of the Controls gallery, on the Design tab), the wizard starts when you click then click in a suitable position on the form. The wizard takes you through the process of creating the combo box with suitable values for the rows of the drop-down list. This wizard works in a similar way to the option group wizard (above). The choices that are offered to the user may be typed directly into the wizard, or the combo box can fetch them from a table field that you nominate (this would be appropriate if there is a join set up between the two relevant tables).
7.6 Using the Combo Box in Form View

In Form View, when the user clicks on the grey arrow button, the menu of permissible values drops down and the user can click on their chosen value. The combo box then rolls away, showing only the value that has been chosen.

7.7 Importance of Combo Box for Related Join Data

When two tables are joined by a relationship, a combo box is the most intuitive and accurate way for a (human) user to add data for the joining field. For example, in a form which shows one record per student, when assigning a student to a particular college it would be inefficient if the user needs to look up the ID number (primary key) for each college so as to type it in. Most users would prefer to look at a list of college names, and click on the appropriate one.

So on a form you would usually replace a text box where an ID number is to be typed in, with a combo box which lists suitable text phrases from the related table.

Relationships between tables are discussed in the course “Databases: Building a database using Access” (see part 15.2 below).

7.8 List Box

A list box works in a similar way to a combo box, but the set of permissible values is always visible in the box (whereas a combo box list is hidden after the user has made a choice). It is also created using a wizard (triggered after you have clicked and marked a suitable position on the form).

7.9 A Combo Box For Finding A Record - Optional

Another use for a combo box is to help the user navigate between records, moving them immediately to a desired record. Such a combo box would typically be placed in the Header.

For example the combo box might offer a list of the given names & family names of all the people in an employee database. The user could choose a name and immediately see that person’s record details.

As before, clicking will start the Combo Box Wizard (see above). The third option is to Find a record...
Databases: User-friendly databases using Access

Figure 22 Starting the Wizard For a “Find A Record” Combo Box

You can choose the fields whose value you want to see listed in the combo box. This may be one or more columns.

Figure 23 Choosing Fields for a Combo Box

In Form View, the user clicks the grey arrow on the new combo box, to see the list of available values. They click the desired value on the list. Access then displays the record which contains that value.

7.10 Editing a Combo Box or List Box

Once a combo or list box has been created, its properties can be changed. When the combo box or list box is selected in Design View, clicking will display the Property Sheet if necessary.
The appearance or behaviour of the control can be changed by editing its properties. In addition to the properties discussed earlier, on the Data tab you can:

- add an item to the list of permissible values
- set a default value
- set Limit To List to Yes (then a user must choose from the values offered)

![Property Sheet](image)

**Figure 24 Adding Another Value to the Combo Box**

**Exercise 9: Adding and managing combo boxes**

Now look at this exercise (page 69).

**7.11 Pictures on a Form (Optional)**

If a graphic or image is needed as decoration on the form, and does not change with the record, it can be inserted as a passive picture object on the form, perhaps in the header or footer. Use ![Image](image) on the Design tab.

If a different picture is needed for each record, for example a photo of each employee, this is stored as an Attachment field in the table. Read more about storing images in a database and displaying them using forms, in an article in the ITLP Portfolio (visit [http://portfolio.it.ox.ac.uk](http://portfolio.it.ox.ac.uk), search for “images databases”, and download the article).

**7.12 Adding a Chart on a Form**

Typically, a chart is included in a form or report as a way of summarising data from many records. ![Chart](image) on the Design tab starts the Chart Wizard. This wizard leads through the steps of choosing data, chart type and layout options.
8 Form Structure

8.1 Sections, Headers and Footers

A form is divided into sections. The Detail is the main portion at the middle of the form, whose contents change from record to record. The Form Header and Footer appear at the top and bottom of the window in Form View. The header and footer content (labels, graphics or field controls) does not change as the user moves between records.

If necessary, a header and footer section become visible when a logo, title or date/time control are added (Logo, Title or Date and Time can be found on the Design tab of the Form Design Tools).

A label or graphic can be added on a Header or Footer in the same way as in the Detail (see part 7.11 above).

The size of any header or footer can be changed by dragging the grey divider bars between Header, Footer and Detail sections, or by dragging the edge of the section.

8.2 Tab Order

A user may choose to move between the controls on a form using TAB instead of the mouse. They will expect to move from one control to the next in an order which matches the layout on the form. This tab order can be revised in Design View.

The Tab Order dialog is displayed by using.

![Figure 25 Managing the Tab Order](image)
With the **Detail** section selected on the left, the controls are listed on the right, in the current tab order. Clicking **Auto Order** will arrange the controls in order, roughly following their positioning on the form. An individual control can be selected in the list (click the grey button beside a field name) then dragged and dropped upwards or downwards, until the order is as required.

### 8.3 Tabbed Pages On A Form

If there is a large amount of data to be shown on a form, it may be convenient to arrange the controls in a series of tabbed pages. The tabbed pages should be set up on the form first, using **.** Then field controls are added onto one or other of the tabbed pages.

Properties of the tabbed page are displayed using **while** the individual tabbed page is selected. In the Format sheet, a **Caption** can be entered, and this will appear on the tab.

To add a further page, use **(this button appears in the Controls gallery when a set of tabbed pages is present).**

In Form View, one tabbed page is displayed at a time. Users will click the tabs to switch between pages.

**Exercise 10: Form structure**

Now look at this exercise (page 71).

### 8.4 A Form Showing Multiple Records

Most forms are designed to show just one record at a time. The user uses the navigation controls **Record:** at the bottom of the form to move from one record to another.

However, with some forms it would be better to show several records at once, perhaps with their data tabulated across the screen. This would be a good use of a Tabular Layout (covered in the later course on Reporting with Access, see part 15.3). The Default View of the form must be set to **Continuous Forms**, in the Property Sheet.

![Figure 26 Setting the Default View to Continuous Forms](image_url)
in the **Create|More Forms** menu offers another way to create this type of layout, in a new form.

With this layout, the user can read several records at a time, and scroll between them.

![Figure 27 Using a Multiple-Record Form](image)

**Exercise 11: A multiple record form**

Now look at this exercise (page 73).

8.5 **Working With Layouts on a Form**

A collection of controls on a form may be organised into a predefined grid-like structure called a *layout*. The objects in a layout are treated as a set and moved, resized or formatted in concert.

Working with layouts is similar, whether in a form or in a report. We will cover it in a later course on reporting (see part 15.3), but you can apply the same approach when working on forms.

![Figure 28 Field Controls in a Layout (in Form Design View)](image)
9 Subforms

If there is a one-to-many relationship between two tables in a database, it may be useful to display the data using a main form that contains a smaller subform. The subform shows only those records which relate to the subject of the main form.

For example, in a personal address list, the main form may show the households one at a time, with their shared address, and the subform may list all the people in a given household, each with their own birthday.

Provided the relationship has already been set up between the tables, using Access’ Relationships diagram, a wizard helps with creating a subform with the correct links.

![Figure 29 Tables With a One-to-Many Relationship](a number of events may take place at a given venue, over a period of years)

9.1 Creating a Subform On a Form

In Design View, clicking and dragging a rectangle on a form starts the wizard.

In the wizard, you choose the data source for the subform, and specify which fields are to be displayed. Access uses the existing relationship between tables to construct the subform.
9.2 Using the Subform On the Form

The subform is placed on the form (although at first it may not look very elegant, you can adjust it later).

In Form View, the subform displays only records which relate to the record shown in the main form. A separate set of navigation buttons is used for moving among the records of the subform. As you move to another record on the main form (using the main set of navigation buttons as usual), the subform changes to display only records which relate to the new main form record.
Exercise 12: Creating and using a subform

Now look at this exercise (page 74).

9.3 Modifying a Subform On the Main Form

Some changes can be made to the way the subform appears, while working on the main form in Design View. For example, extend the space allowed for showing the subform, by dragging a handle on the subform.
The appearance of the subform can be changed using toolbar buttons or the Property Sheet as usual.

9.4 Opening a Subform for Editing

The subform wizard has already saved the subform, as a separate form with its own form name listed in the Navigation Pane.

The convention for naming subforms is to use the prefix **sfr**.

A subform can be selected then opened using its entry in the Navigation Pane. The subform opens in Datasheet View – just as in subform display. Here you can:

- drag the column dividers to adjust the column widths
- rearrange the order of columns by dragging and dropping
- change the sort order by clicking in a column and clicking **Ascending** or **Descending**
- make limited font formatting changes to the whole dataset, using the toolbar buttons

**Exercise 13: Editing a subform**

Now look at this exercise (page 77).
10 User Interface

It is worth spending some time making the database easy and efficient to use. This will encourage the people to use it, and is likely to help them enter and work on the data accurately.

A user interface is a set of forms and reports which are designed to work efficiently together, so the user moves between them to work on the data. Macros may be set up so that some actions take place automatically. Command buttons may be added, which the users click when an action or macro is needed. A navigation form helps the users to move between forms and reports without being distracted by the detailed objects in the database.

For creating some of these features, the database file must be trusted. By default, macros are not permitted to run unless they are in a trusted location. Read about saving a database in a trusted location, or making a location trusted, in Appendix 1.
11 Command Buttons

11.1 Command Buttons in a form

It may be useful to include buttons in a form, which the user can click when they want certain actions to take place. A command button may run a macro or trigger some other event. For example, it may be useful to provide buttons in a form so that the user can easily print out the current record, or go to a different form.

![Figure 33 A Form With a Command Button for Printing](image)

When the form is in use, the user decides when to click the command button and carry out the action.

11.2 Creating a Command Button

When a form is designed, a button can be placed in a convenient place such as the header or footer. A wizard helps you set this up, using [Use Control Wizards]. Provided that [Use Control Wizards] is already depressed, the Command Button Wizard starts.

A single action is chosen from a list in the wizard (if you need a sequence of actions, first create a macro then attach it to a command button: this is covered in part 12 below).
Then you choose a picture or text for the button face.

Note: When you give the button a name, do not re-use button names in a form. Each new button must have a new name. This is because when a button is created, a block of Visual Basic code is automatically made which operates the button and uses its name. If a button is deleted from the form, the VB code is not deleted, so another button with the same name introduces an ambiguity in the code. The user will be faced with alarming VB error messages.
When the form is used, the user decides when to click the command button and carry out the action.

11.3 Changing the Appearance of a Button

Then fill and border colours of a button can be changed using and (on the Format tab).

A button can be given a whole new look (colours, borders, and shading) by applying a Quick Style or even changing its shape .

**Exercise 14: Command buttons in a form**

Now look at this exercise (page 78).
12 Macros

12.1 Using Macros in an Access Application

A macro is a sequence of commands or actions, which is saved with a macro name so it can be run whenever it is needed. This may be useful for carrying out repetitive or difficult tasks. A family of macros may be included in an Access file, to automate or streamline work.

A macro may be run on demand from the Navigation Pane, or it may be set to run on a specified event or when the user clicks a special button.

![List of Macros Showing in the Navigation Pane](image)

12.2 Building a Simple Macro

A new macro may be created by building up a list of commands (choosing commands from a list), or by using a wizard with a new command button on a form. There is often no need to type complex lines of code.

On the Create tab, click \(\text{Macro}\) to start creating a new macro. The Macro Design View is shown. A new macro is built by choosing commands from a list. A sequence of commands is set up, listed down the first column in the order they are to be executed.

When you click \(\text{Add New Action}\), the drop-down list offers a choice of macro commands. Alternatively, browse the available commands listed in the Action Catalog at the side of the window.
The next action is chosen in the next row and so on until a sequence of actions has been built. With an action selected, a panel of its parameters is shown. Here you give further details, for instance specifying which form is to be opened if the Action is **OpenForm**.

The actions will be executed in the order listed. They can be rearranged by dragging and dropping.

When the macro is closed, it should be given a name – conventionally an Access macro name is prefixed with **mcr**.

Once a macro has been saved, it can be re-opened for further editing by right-clicking the macro name in the Navigation Pane.
12.3 Running a Macro From the Navigation Pane

Macros are listed in the Navigation Pane. A macro can be run by selecting the name and pressing ENTER or by double-clicking the macro name.

Alternatively, a macro can be run from any window by using \textdollar{run macro} on the Database Tools tab, then choosing the desired macro by name.

Exercise 15: Creating macros

Now look at this exercise (page 79).

12.4 More Commands for a Macro

If your macro needs to carry out a command that is usually available through the ribbon and menus, but that does not seem to appear on the list of macro actions, more are available through the \texttt{RunMenuCommand} macro action (as shown in Figure 40).

![Figure 40 More Commands Available in the RunMenuCommand Macro Action](image)

Exercise 16: More macro commands (Optional)

Now look at this exercise (page 81).
12.5 A Macro That is Run Using a Button

A button on a form can be an alternative way for users to run a macro. The macro should usually have been written and saved beforehand (its name appears in the Navigation Pane). With the form open in Design View, a command button is created by clicking on the Design tab, and then clicking at a suitable position on the form. The Command Button Wizard starts (provided that is active).

![Command Button Wizard](image)

**Figure 42 Command Button Wizard (1)**

The Miscellaneous category includes the Run Macro action. From here, the wizard runs as described above (part 11.2 above).

12.6 Attaching a Macro to A Form or Report (Optional)

A macro, once written, can be set to run when a particular form or report opens. With a form open in Design View, the form’s own properties can be displayed by double-clicking the form selector (black block at top left corner of the form).
The **Event** tab shows a number of events that are associated with a form. Clicking opposite an event displays a drop-down list where you can choose from the macros already created.

For example, when a form comes to the front of other windows, it fires an event named **On Activate**, so this is the event to attach a macro if you want it to be carried out as the user opens the form and prepares to work on it.

Alternatively, click the Build button beside the chosen event, and choose the **Macro Builder**. With this you can build a new macro as described earlier, and save it with a suitable name.

---

1 A helpful article explaining the sequence of events for forms, reports and individual objects is at [http://functionx.com/access/Lesson17.htm](http://functionx.com/access/Lesson17.htm)
When someone uses the form and the nominated form event occurs, the macro runs.

The same procedure is used to attach a macro to a report event.

12.7 A Macro That Runs When the Database Starts

Any macro that is named AutoExec will run as the database starts.

How to over-ride: hold down SHIFT while opening the database, if it is necessary to bypass this and any other startup settings.

Exercise 17: Macros in a form

Now look at this exercise (page 82).
13 A Navigation Form

It may be convenient to set up an extra form which shows no actual data but which offers the user a set of buttons. These help people to navigate among the forms and reports in a database. This acts as a switchboard or navigation form. Users may work entirely from this navigation form, clicking its special set of buttons to move among the forms and reports, and never actually seeing the Access Navigation Pane with its lists of objects.

13.1 Creating a Navigation Form

A navigation form offers the user a set of buttons, each leading to a different form or report. 

This work is most conveniently done in Layout View (found using 
 on the Create tab offers several variants.

![Alternative Types of Navigation Form](image)

**Figure 45 Alternative Types of Navigation Form**

This work is most conveniently done in Layout View (found using 
 on the Home tab). Layout View will be covered more fully in the course “Databases: Reporting data with Access”. A navigation control appears at the edge of a new form, where you drag the names of forms and reports from the Navigation Pane.
Databases: User-friendly databases using Access

Exercise 18: Building a navigation form

Now look at this exercise (page 83).

13.2 Changing the Appearance of the Navigation Buttons

While a button (or group of buttons) is selected, its appearance can be changed using the buttons on the Format tab. The Quick Styles offer a good way to transform the buttons.
13.3 Changing the Text on a Navigation Form

If the forms and reports have rather short or cryptic names, it may be helpful to show more familiar words or phrases on the navigation buttons.

The first time you click on a button in Layout View, the button as a whole is selected (relevant if you plan to change its appearance). When you click a second time, a flashing text insertion point appears, which you can use to edit the text as when word-processing.

It may also be helpful to edit the title box in the header, and the form’s caption which appears on the tab at the top of the form.

13.4 Using a Navigation Form

A navigation form is opened in the same way as other forms (e.g. by double-clicking the form name in the Navigation Pane).
Databases: User-friendly databases using Access

Now the buttons can be used to run the various forms and reports. Whenever a button is clicked to run a form or report, *current* data from the underlying tables is presented. Each form or report can be closed as usual by using \( \times \), to return to the navigation form.

**Exercise 19: Improving the look of a navigation form**

Now look at this exercise (page 84).
14 A Startup Form

14.1 Creating a Startup Form

One form may be nominated as the *startup form*: the one that appears when the database file is opened. The navigation form would be a good choice for this, if you have one.

The Startup options are found among the Options, reached via the File menu.

![Image](Figure 50 Locating the Access Options on the File Menu)

In the **Current Database** category, you can make settings which will control the behaviour of the database currently open.

![Image](Figure 51 Current Database Options)

Here you can nominate a form which will be displayed on startup, the **Display Form**. Other settings in this dialog include typing text for the Application Title (a caption which will appear in the Access title bar when this database application is in use), and displaying or suppressing the Navigation Pane.

The startup options will be effective next time the database file is opened.
14.2 Compacting the Database

It is good practice to set the database to **Compact On Close**. When a database is used, and data is added, edited and deleted, gaps may be left among the data which uses up disk space and may lead to a risk of file corruption. Access can compact the data each time the database is closed, reducing this problem. This setting is found among the **Options for the current database** in the **Access Options** (see Figure 51 above).

14.3 Over-riding the Startup Options

The designer of a database may sometimes need to open the file without the Startup options, when designing or revising the database interface. In this case, hold **SHIFT** while opening the file, to over-ride the Startup settings.

14.4 Publishing the Finished Database For Users

When all the design work, the forms, reports and so on, are finished, it may be useful to publish the database. The **Save As** command on the **File** menu includes the option to **Make an ACCDE** file. This type of database file is executable-only. A user who has this version can work on the data using the forms and reports provided, but cannot modify the design.

You would keep a copy of the .accdb file in a safe place as an archive, which would be needed if the design was to be changed.

**Exercise 20: Startup options**

Now look at this exercise (page 86).
15 What Next?

Now that you have some useful Access skills you may want to develop them further. IT Learning Programme offers a range of resources for study and teaching.

15.1 Downloadable Course Materials and More - the ITLP Portfolio

These and other course materials are available through the ITLP Portfolio, at http://portfolio.it.ox.ac.uk.

Each course pack includes the course handbook in pdf form and a zip folder of the exercise files that you need to complete the exercises. Archive versions of the course book may also be useful if you use an earlier version of the software.

The ITLP Portfolio helps you find articles, videos, resources and weblinks for further IT study. For some resources, you will be asked for your Oxford (SSO) username and password.

It may be possible for you to use the facilities at IT Services to work through the exercises in this booklet, or use any of the applications that are available. Contact us on courses@it.ox.ac.uk for details.

15.2 Database Courses Which Precede This

Databases: Concepts of database design
Databases: Building a database using Access

15.3 Database Courses Which May Follow This

Databases: Reporting data using Access
Databases: Querying and analysing data using Access

Read about the content of these courses in the IT Learning Programme Catalogue at www.it.ox.ac.uk/itlp/courses/catalogue

15.4 Course Clinics

We encourage everyone to work at their own pace. This may mean that you don’t manage to finish all of the exercises for this session. If this is the case, and you would like to complete the exercises while someone is on hand to help you, come along to one of the Course Clinic sessions that run during term time. More details are available from www.it.ox.ac.uk/courses/

15.5 IT Services Help Centre

The Help Centre is also a good place to get advice about any aspect of using computer software or hardware. For Help Centre opening times, visit www.it.ox.ac.uk/help/gettinghelp/ and follow links to the General Helpdesk, or contact them by email on help@it.ox.ac.uk.
Appendix 1: Viruses and Security Levels in Access

Why Worry About Viruses?

A virus is malicious code that may arrive from another computer, and copy itself onto your hard disk. Depending on the taste of the person who devised it, it may be just a joke, or it may destroy data or system files. Some viruses send themselves on to other people via your email setup.

A virus may infect your computer while you are connected to the internet, or it may arrive attached to an email or on a contaminated removable disk, and it may take the form of a macro in an Access database file. It is essential to make provision for your computer to be scanned frequently for any viruses which may have arrived.

Scanning for Viruses

Virus Scanning Software

You should install and use virus-checking software such as Sophos (supported by IT Services). Other popular virus-checkers include McAfee VirusScan and Norton AntiVirus. Contact the Online Shop or visit www.it.ox.ac.uk for more information about obtaining Sophos at no cost or low cost for University members.

A typical virus-checker scans your computer disks according to a preset schedule. For instance, it may be set to check the hard disk every time you start Windows, or twice a week, or to scan every document on opening. The program detects any viruses, then alerts you and gives the options of deleting the file, putting it in quarantine or perhaps fixing it.

Keeping the List of Viruses Up-to-date

A virus-checking program must be kept up-to-date. It is important to connect frequently to the virus-checking centre (this is typically done via their internet website). The virus list on your computer is then updated with all viruses known to date, with any antidotes.

Access 2013 and Virus Security

Access 2013 considers any database file (such as .accdb or .mdb) as a potential route for virus infection. It starts by disabling any automatic content, and then asks you to decide whether to enable it.

This applies to content such as macros and some Control Wizards and ActiveX Controls.

Information about the other levels of protection, and further options for the way Access handles macros, is given in Access Help.

Security Warning Message

When you open a database file using Access 2013, a Security Warning message may appear in a white/yellow bar near the top of the window.

---

Access 2007 and 2010 handle viruses in a similar way to Access 2013
If you do not expect to use any automatic features, you can safely ignore this message and continue work.

**Enabling Automatic Content For Just One Visit**

Enable Content on the Security Warning bar gives you the opportunity to enable any automatic content that may be present: only do this if you are sure that the database file comes from a safe source and does not contain any virus or other hostile code.

Note that the decision to Enable this content is effective for this session only. If the database is closed, then the decision will need to be repeated each time it is opened. This may be a convenient and cautious approach to take.

**Trusted Locations in Access 2013**

Some locations (folders, drives or devices) can be nominated as Trusted Locations: Access then considers any database files found there to be trusted, and their automatic content is permitted to run.

So you may find it convenient to nominate a folder or area on your computer or your network as being Trusted by Access. Then make sure that all your Access database files are saved there.

This decision may be reached in consultation with colleagues and other users of the database, and with your local IT support contact. Some departments have a policy about where computer files of different kinds should be saved.

For example, in our teaching rooms, the students’ files are provided for you on a drive known as H:\, and this has been set as a Trusted Location in the installed copies of Access. Computers at IT Services have Sophos virus protection software which is kept up-to-date. If you are in an IT teaching room, you can rely on Sophos to manage the virus scanning.

The program files for Access are placed in a Trusted Location, by default.

**When to Trust a Location for Access 2013**

You should only consider doing this if you do need to use automatic content such as macros, and if you have made very good arrangements to protect the computer from virus attack.

If you are using a University- or College-owned computer, take advice from your local IT Support Staff before making a location Trusted. Ensure that you have reputable virus scanning software installed, and that you keep its files of known viruses up-to-date (i.e. it checks at least weekly by connecting to the software...
Databases: User-friendly databases using Access

provider and downloading the latest lists). Then confirm that the software is configured to scan every file as it is opened.

Only once this is in place can you rely on the virus scanning software to do the virus scanning, and use Access to manage your database files.

**Finding the Access Trust Center**

You may decide to set Access to Trust a folder or computer storage area. This is done in the Trust Center, which is among the Access Options (found on the File menu).

In the left-hand column of the Access Options dialog, choose the Trust Center category. This reveals the button on the right.

![Figure 53 The Trust Center With the Trust Center Settings Button](image)

Figure 53 The Trust Center With the Trust Center Settings Button
How to Trust a Specific Location with Access 2013

Figure 54 The List of Trusted Locations

Trusted Locations (found in the category list on the left) shows which locations have already been treated as trusted. Here you can Add new location... or Modify... Beware that if you add a location to this list, you are no longer protected from active content saved in that location.

If the location where you plan to save your databases is on a network drive, check Allow Trusted Locations on my network in the same dialog. You should consult the IT support contact who is responsible for the network, before doing this.

You may also decide to trust subfolders within the chosen location – there is a check box for this in the Trusted Location dialog.

Figure 55 Trusting Subfolders in a Trusted Location
Once a folder has been Trusted, save all database .accdb files there.

**Sandbox Mode**

Note that these choices make *Access* run in a controlled and limited way, known as *sandbox mode*. In sandbox mode, *Access* will run a reasonable range of commands and functions. Occasionally, some macros created using older versions of *Access* may need to be re-written using revised commands which are now permitted.

In sandbox mode, some commands are disabled because they are deemed potentially unsafe, and could be used maliciously to damage your files or system. A user can only disable sandbox mode by changing keys in the *Windows* registry, which is not a task for the inexperienced to attempt (if you are not perfectly familiar with working in the *Windows* registry, don’t experiment: ask someone who has experience, as there is a risk of making the computer unusable).

**Further Help with Security and Trust Center Settings**

There is a range of further settings available through the Trust Center. Read more about this in *Access’* Help.
Appendix 2: Student Exercises

Exercise 1  Opening a database file

- Start Access
- Open an existing database file
- View the list of tables, forms etc
- Using an existing form
- Using a form to view or edit data

All the files for these exercises have been provided for you on a network drive. Your area of the drive is called drive H:\
This drive has been set up as an Access Trusted Location

In the Pendleton Products database, a small company is keeping track of its employees, customers and orders

Task 1
Start Access from the Start menu

Step 1
Start the computer if necessary

Step 2
Click on the taskbar at the bottom of the screen
In the Start menu, explore the folders and look for the Microsoft Office folder
Choose Access

Step 3
If you are prompted for any user information, just click on OK

Step 4
(On your office or home computer you may start the program using an Access icon on the Desktop)

Task 2
Access 2013 can also be used to create an app database: where users work on the data via a web browser. This would require communication using Office 365 or SharePoint 2013, and is not the subject of this course. We will work on a desktop database, which is saved locally on your computer or a network drive.
| **Task 3** | **Step 1** |
| **Open **Pendleton Products.accdb** | **Choose File | Open** |
| | Or click [Open Other Files] in the backstage view |
| | **Step 2** |
| | Browse to the network drive called drive H:
| | Alternatively, navigate to a drive and folder as directed by your teacher |
| | All the files you need for this course will be found here |
| | **Step 3** |
| | Locate the file called Pendleton Products.accdb |
| | Open the file by selecting the filename then clicking |
| | **Step 4** |
| | If a security warning bar appears, stating that certain content in the database has been disabled, then read Appendix 1 |

**Task 4**
Look at the relationships diagram to see the tables and joins in this database
In this database, a small business is keeping track of the orders it has received, with the customers it deals with and the employees who manage the orders
When ready, close the Relationships diagram

| **Task 5** | **Step 1** |
| **Use the Navigation Pane in the database window** | **Select ☐ next to the title of the Navigation Pane (on the left-hand side of the screen)** |
| | Select Object Type (under Navigate To Category) |
| | **Step 2** |
| | Select ☐ again and choose All Access Objects (under Filter By Group) |

| **Task 6** | **Step 1** |
| **Look at the list of tables, forms and other objects in the Navigation Pane** | Notice that the names of tables and forms that have already been created are listed in the Navigation Pane |
| | **Step 2** |
| | Data is stored in the tables |
| | Forms are used for viewing or editing the data |
### Task 7

**Run **frmEmployees** from the Navigation Pane**
- Edit some data values
- Close the form

**Step 1**
- In the Navigation Pane, find the form named frmEmployees
- Run it by selecting the form name and pressing ENTER, or by double-clicking the form name

**Step 2**
- This form shows just one record at a time; use the navigation buttons (at bottom left) to move among the records
- Navigate to the record for Keith Simpson

**Step 3**
- Use TAB and SHIFT+TAB to move among the fields of a single record
- Correct his salary to 20000 (do not type the £ symbol, it will be added by Access as part of the currency format)

**Step 4**
- Correct his middle name to Arthur
- Close the form

### Task 8

**Close all forms, leaving the Navigation Pane and Pendleton Products.accdb still open**

### Exercise 2  Creating a form using the wizard

- Creating a form using the wizard, based on a table
- Saving the forms (using naming convention)

### Task 1

Continue working in the file Pendleton Products.accdb
- Close any tables, queries, or forms that may be open, using **×**

### Task 2

Start the Form Create wizard
- Choose tblCustomers and all fields
- Choose Justified layout
- Give a suitable name for the form, with the prefix frm

**Step 1**
- Click **Form Wizard** on the Create tab of the ribbon

**Step 2**
- In the wizard, choose tblCustomers
- Select all the fields available, using **>>**

**Step 3**
- Choose the Justified layout

**Step 4**
- Name the form frmCustomers
- Click **[ ]** to view the form in Form View
### Databases: User-friendly databases using Access

**Task 3**
Look at the form you have made – here you can view and edit existing data or add new data.

The data is stored in **tblCustomers**

---

### Exercise 3  Creating a blank form

- *Create a blank form in Design View*
- *Extend the working area of the form*
- *Show or hide gridlines and rulers*
- *Save the form*

---

**Task 1**
Continue working in the file **Pendleton Products.accdb**

Close any tables, queries, or forms that may be open, using **×**

**Task 2**
View the list of forms in the Navigation Pane

If necessary, use **Forms** in the Navigation Pane, to view the list of forms

**Task 3**
Create a new form in Design View

**Step 1**
On the **Create** tab of the ribbon, click

The new form appears in Design View

**Task 4**
Show rulers and gridlines

**Step 1**
On the **Arrange** tab, click

**Step 2**
Show the gridlines using **Grid**

The gridlines will not show when the finished form is used

**Step 3**
Show rulers along the top and left edges of the form, using **Ruler**

**Task 5**
Extend the working area of the Detail

**Step 1**
Drag the right edge of the white working area, to make the Detail space wider

**Step 2**
Drag the lower edge to make the Detail space deeper
**Task 6**  
Save the new form, calling it **frmFirst**  
Close **frmFirst**

<table>
<thead>
<tr>
<th>Step 1</th>
</tr>
</thead>
</table>
| Click \ or choose **Save** on the **File** menu, and save the new form  
| Call it **frmFirst** |

<table>
<thead>
<tr>
<th>Step 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Close the form using \</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Step 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>Notice the new form name appears in the Navigation Pane</td>
</tr>
</tbody>
</table>

---

**Exercise 4**  
Adding and manipulating field controls on a form

- Add a number of field controls
- Select a text box control and its associated label
- Edit label text
- Move and resize a text box control and its associated label

**Task 1**  
Create a new form in Design View  
If necessary, show the Field List

<table>
<thead>
<tr>
<th>Step 1</th>
</tr>
</thead>
</table>
| Continue working in **Pendleton Products.accdb**  
| Click \ to create a new form in Design View |

<table>
<thead>
<tr>
<th>Step 2</th>
</tr>
</thead>
</table>
| If the Field List is not visible, click \  
| Move the list to a convenient position by dragging its title bar |

**Task 2**  
Add a text box control for the field **CompanyName** in the **tblCustomers**  
Place it near the top of the Detail section

<table>
<thead>
<tr>
<th>Step 1</th>
</tr>
</thead>
</table>
| Click **Show all tables**  
| Click \ beside **tblCustomers**, to display the fields in that table |

<table>
<thead>
<tr>
<th>Step 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Drag the <strong>CompanyName</strong> field name from the Field List and drop it onto the form, near the top of the Detail area</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Step 3</th>
</tr>
</thead>
</table>
| When the mouse is let go, a new control is added on the form  
| The control is automatically bound to the **CompanyName** field from the table **tblCustomers** |
### Task 3
Add more text box controls, placing them just below the `CompanyName`

**Step 1**
In the Field List, click on `ContactFirstName`, then hold SHIFT and click on `ContactLastName`.
When both are selected, drag them onto the form just below the `CompanyName` control.

**Step 2**
Repeat this process, clicking `CompanyOrDepartment` in the Field List, holding SHIFT and clicking `Notes`, then dragging these selected fields onto the form.

**Step 3**
Adjust the height and width of the form as necessary.

### Task 4
Edit the label `CompanyName:` to read `Company Name`

**Step 1**
Select the label `CompanyName:`
Click inside the label box, until an insertion point appears.

**Step 2**
Edit the text to read `Company Name`.

**Step 3**
Edit other labels if you wish.

### Task 5
Move the four address text boxes into a space on the form, perhaps forming a right-hand column.

**Step 1**
Select the `BillingAddress` down to `Country` text boxes (hold CTRL for multiple selection).

**Step 2**
Move the selected boxes by dragging using the 4-headed arrow pointer.
Move them to a space on the right of the form.

**Step 3**
Move other controls as convenient.

### Task 6
Resize the `CompanyName` label to be large.
Then use Size to Fit to resize it again.

**Step 1**
Click on the `CompanyName` label.

**Step 2**
Drag a corner handle to make the label rather larger than is needed.

**Step 3**
On the Arrange tab, choose `To Fit` then choose `Fit` to fit the label neatly around its text.

### Task 7
Run the form and edit some data.

**Step 1**
Select `View` to view your changes in Form View.
## Step 2
Enter or modify some data using the form

### Task 8
Close the form, saving changes

### Step 1
Click ✗ to close the form

### Step 2
When prompted to save changes to the form design, choose Yes

## Exercise 5  Manipulating multiple field controls on a form (Optional)
- Select several objects on a form
- Understand the stacking order of overlapping objects
- Move objects forwards and backwards in the stack

### Task 1
Open frmDetailsOfCustomers in Design View

### Step 1
Continue working in Pendleton Products.accdb

### Step 2
Right-click frmDetailsOfCustomers in the list of forms then choose Design View

### Task 2
Practice selecting several objects by holding CTRL while clicking objects

### Step 1
Click on the PhoneNumber text box
Hold CTRL and click on the Extension box
Hold CTRL and also click on the EmailAddress box
Now all of three boxes are selected

### Step 2
Drag all the selected boxes a little to the right

### Step 3
When finished, click the grey desktop to deselect everything
### Task 3
Rearrange the icon and the text box in the Form Header, swapping them from front to back

#### Step 1
In the Form Header, there is a form icon and an orange text box
Drag the icon until it overlaps the orange text box
Notice the way they are stacked – which one is in front?

#### Step 2
Use \[\text{Bring to Front}\] and \[\text{Send to Back}\] to explore their effect on the stacking order of the icon and the text box

### Task 4
Close the form \texttt{frmDetailsOfCustomers}, saving changes

#### Step 1
Click \[\text{X}\] to close the form
When prompted to save changes, choose \texttt{Yes}

### Exercise 6  Formatting controls and labels on a form
- Using a theme to change the appearance of a whole form
- Formatting text in a field box on a form
- Colour fills and borders around controls and labels
- Changing background colours

### Task 1
Continue working in \texttt{Pendleton Products.accdb}

### Task 2
Open \texttt{frmDetailsOfCustomers} in Design View

#### Step 1
Open the form \texttt{frmDetailsOfCustomers}
If necessary, right-click on the form name in the Navigation Pane then select \texttt{Design View}

#### Step 2
Check that you are working in Design View

#### Step 3
Notice that the \texttt{Form Design Tools} tabs appear

### Task 3
Use the Themes Gallery to change the formatting

#### Step 1
Click \[\text{A}\] on the \texttt{Design} tab, to display a gallery of theme options

#### Step 2
Select any one of the themes

#### Step 3
Notice how the font, colours, and borders of the whole form are affected
### Task 4
Change the font size for the **Company Name** field and make it bold

**Step 1**
Select the control for the field **Company Name**

**Step 2**
Change the font size to **18 point** using the font tools on the **Format** tab

**Step 3**
Use a [B](https://example.com) button to make this text bold

### Task 5
Change the fill and border colours for the **Email Address** field

**Step 1**
Select the control for the **Email Address** field

**Step 2**
Click the dropdown arrow for [ ] on the **Format** tab and change the fill colour (e.g. to yellow)

**Step 3**
Click the dropdown arrow for [ ] on the **Format** tab and change the border colour (e.g. to red)

**Step 4**
Experiment with changing the colours and borders of other controls and labels, using the options on the **Format** tab

### Task 6
Change the background colour of the form detail

**Step 1**
Click on the background of the form (i.e. not on a control or label)

An orange border should appear around the Detail section of the form

**Step 2**
Use [ ] on the **Format** tab to change the background colour of the form detail to something suitable

### Task 7
Run the form

Save changes

**Step 1**
Select [](https://example.com) to view your changes in Form View

**Step 2**
Click [ ] on the Quick Access Toolbar, to save this form

### Task 8
Leave the form open for the next exercise
**Exercise 7  Using the Property Sheet (for a Form)**

- Display the Property Sheet (and review some of the changes made recently)
- Change some Format properties
- Change a Data property
- Change an Other property
- Change a property of the Form itself

**Task 1**
Continue working in **Pendleton Products.accdb**, with **frmDetailsOfCustomers** in Design View

<table>
<thead>
<tr>
<th>Task 2</th>
<th>Step 1</th>
</tr>
</thead>
<tbody>
<tr>
<td>If necessary, display the Property Sheet</td>
<td>Confirm that you are working in Design View</td>
</tr>
</tbody>
</table>

**Step 2**
If the Property Sheet is not visible, click on the **Design** tab of the ribbon

**Step 3**
Move the Property Sheet to a convenient place, by dragging its title bar

<table>
<thead>
<tr>
<th>Task 3</th>
<th>Step 1</th>
</tr>
</thead>
<tbody>
<tr>
<td>Look at the properties of the <strong>CompanyName</strong> control in the Property Sheet – those in the <strong>Format</strong> page will be as you set earlier, using the buttons</td>
<td>Select the <strong>CompanyName</strong> control</td>
</tr>
</tbody>
</table>

**Step 2**
The properties of this control are now shown in the Property Sheet

**Step 3**
Click the **Format** tab on the Property Sheet
Notice that some of the formats set here are the values you set earlier when you were using buttons

**Step 3**
This is an alternative way of making the same changes you made earlier using toolbar buttons
With the **CompanyName** control selected, set the Font Size to 18

**Step 4**
The Property Sheet offers many more properties
Change the Special Effect (on **Format** tab) to **Shadowed**

<table>
<thead>
<tr>
<th>Task 4</th>
<th>Step 1</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use the Property Sheet, <strong>Data</strong> tab, to set a default value of <strong>Oxon</strong>, for the <strong>Country/Region</strong> control</td>
<td>Select the <strong>Country/Region</strong> control</td>
</tr>
</tbody>
</table>

**Step 2**
In the Property Sheet, click the **Data** tab
In the Default Value box, type **Oxon**
### Step 3
Now whenever a user creates a new record using this form, the default value of **Oxon** will be entered (the user can over-write this value as necessary)

<table>
<thead>
<tr>
<th>Task 5</th>
<th>Use the <strong>Other</strong> tab of the Property Sheet to enter a ControlTip text for the <strong>Notes</strong> control, such as <strong>Please give any further relevant information here</strong></th>
</tr>
</thead>
</table>
| **Step 1** | Select the **Notes** control  
In the Property Sheet, click the **Other** tab |
| **Step 2** | For the ControlTip Text, type **Please give any further relevant information here**  
Now when a user pauses the mouse pointer over the Notes box, they will see a ControlTip with your helpful message |

| Task 6 | Look at the properties of the form itself  
Give the form a caption such as **Pendleton Products, Lancs** |
|--------|--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------|
| **Step 1** | Use the combo box at the top of the Property Sheet to display the properties of the Form itself  
In the **Format** tab |
| **Step 2** | In the Property Sheet, click the **Format** tab  
**Step 3**  
In the **Caption** box, type **Pendleton Products, Lancs**  
Now this caption will appear on the title bar when the users open the form in Form View |

| Task 7 | Examine the effects of your changes in Form View  
Close and save the form |
|--------|--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------|
| **Step 1** | Click **View** to switch to Form View  
Notice all the changes you have made |
| **Step 2** | Return to Design View to make further changes if necessary  
**Step 3**  
Close the form, agreeing to save changes if prompted |

<table>
<thead>
<tr>
<th>Task 8</th>
<th>Close the form (save changes) and close the file <strong>Pendleton Products.accdb</strong></th>
</tr>
</thead>
</table>
| **Step 1** | Click **X** to close the form, saving changes when prompted  
**Step 2**  
Close the database file **Pendleton Products.accdb**, leaving **Access** still open |
## Exercise 8   Adding some special field controls

- Add a checkbox automatically
- Add a date control automatically
- Add an option group using the wizard

### Task 1
Open the database **Woodstock Road Dentist.accdb**

You may recall that a group of dentists uses this database to keep track of the patients and appointments.

If you need a reminder, look at the relationships diagram to see the tables and joins in this database.

### Task 2
Open **frmNotesForPatients** in Design View

<table>
<thead>
<tr>
<th>Step 1</th>
<th>Right-click <strong>frmNotesForPatients</strong> in the forms list and choose Design View</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>The form opens in Design View</td>
</tr>
</tbody>
</table>

Ensure that the Field List is visible (if not, click ![Add Existing Fields](image)).

### Task 3
Add a display of the current time into the form footer

<table>
<thead>
<tr>
<th>Step 1</th>
<th>Click <img src="image" alt="Date and Time" /> on the Form Design Tools tab</th>
</tr>
</thead>
</table>
| Step 2 | Clear **Include Date**  
Check **Include Time** and choose a time format                           |
| Step 3 | A **Time()** object appears near the top of the form                      |
| Step 4 | Drag the lower edge of the grey Form Footer bar, to give the Footer about 1cm depth |
| Step 5 | Drag the **Time()** object into a space in the footer                   |

### Task 4
Insert a text box control with date picker, for the **Date** field

| Step 1 | Drag the field name **Date** from the Field List and drop it onto the Detail section of the form  
Note this is a field from the table, showing the date when a note was made - do not confuse this with today’s date which might be displayed in the footer |
### Task 5
Create a checkbox control for the field **CopyGivenToPatient**

**Step 1**
Drag the field name **CopyGivenToPatient** from the Field List and drop it onto the Detail section.

**Step 2**
A checkbox control is created, because this field was defined as a Yes/No type in the Table Design.

### Task 6  **Optional**
Add an option group for the field **DentistSeen**

Use the wizard, typing the names of 3 dentists

**Step 1**
Ensure that the **Use Control Wizards** is depressed, so that the wizard will start.

**Step 2**
Click **Add**.

Then click in a suitable position on the form.

The wizard starts.

**Step 3**
First, type in the values that are to appear on the list.

**Figure 56 Combo Box Wizard**

Click **Next** to move through the wizard.

**Step 4**
Choose one dentist to be the default choice, if you wish.

**Step 5**
Leave the suggested values of 1, 2 and 3 for the three dentists.
**Step 6**
In the next part of the wizard, specify which field the chosen data values are to be stored in: **DentistSeen**

**Figure 57 Specifying the Field To Be Stored**

**Step 7**
Choose between Option buttons, Check boxes and Toggle buttons

**Step 8**
Finally type the text for the label that will be associated with the option button
Click **Finish** to complete the wizard

**Task 7**
Try out the form in Form View, adding data for a new patient

**Step 1**
Switch to Form View, using

**Step 2**
Try out the new controls which you have added
Add a new patient note with these details:

- **Note ID**: [automatic]
- **PatientID**: 3
- **Date Seen**: 30/11/2015
- **DentistSeen**: (choose one from the list)
- **CopyGivenToPatient**: **Yes**

**Task 8**
Click ✗ to close the form, saving changes if prompted
<table>
<thead>
<tr>
<th>Exercise 9</th>
<th>Adding and managing combo boxes</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Add a combo box using the wizard</td>
<td></td>
</tr>
<tr>
<td>• Edit the properties of a combo box</td>
<td></td>
</tr>
<tr>
<td>• Add a combo box for the related field between tables</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Task 1</th>
<th>Continue working in <strong>Woodstock Road Dentist.accdb</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Open <strong>frmPatientsPlain</strong> in Design View</td>
<td></td>
</tr>
</tbody>
</table>

| Task 2 | Delete the text box for the **Title** field |

<table>
<thead>
<tr>
<th>Task 3</th>
<th>Create a combo box for people's titles</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use the wizard</td>
<td></td>
</tr>
<tr>
<td>Type the values: <strong>Mr, Mrs, Ms, Miss, Dr</strong></td>
<td></td>
</tr>
</tbody>
</table>

| Task 4 | Try out the combo box in Form View – change Peter Green from **Mr** to **Dr** |

<table>
<thead>
<tr>
<th>Step 1</th>
<th>Select the <strong>Title</strong> text box</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>Press DELETE to remove the box (with its label)</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Step 1</th>
<th>Click , then click where the <strong>Title</strong> box had been</th>
</tr>
</thead>
<tbody>
<tr>
<td>The wizard starts</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Step 2</th>
<th>In the first part of the wizard, choose <strong>I will type in the values that I want</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 3</td>
<td>Type the permissible values which your users will be offered (one on each row): <strong>Mr, Mrs, Ms, Miss, Dr</strong></td>
</tr>
</tbody>
</table>

| Step 4 | Choose the field name where the value is to be stored: **Title** |

| Step 5 | Finally type the label text, such as **Give the person's preferred title** |
## Task 5
Add the title **Prof** to the Row Source list for the combo box
Set a default value of **Mr**

<table>
<thead>
<tr>
<th>Step 1</th>
<th>In Design View, select the <strong>Title</strong> combo box</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>Display the Property Sheet (click <img src="image" alt="Property Sheet" />) on the <strong>Design</strong> tab and look at the properties that have been set for the combo box</td>
</tr>
<tr>
<td>Step 3</td>
<td>On the <strong>Data</strong> tab, click in the <strong>Row Source</strong> box and type <strong>Prof</strong> at the end of the list. Take care to follow the existing punctuation: use a semicolon separator and enclose “<strong>Prof</strong>” in quotation marks</td>
</tr>
<tr>
<td>Step 4</td>
<td>Click in the <strong>Default Value</strong> box and type <strong>Mr</strong></td>
</tr>
</tbody>
</table>

## Task 6
Try using the combo box to assign Titles to a few patients.

## Task 7
It would be good to record which school each patient attends (if any).
Schools are listed in **tblSchool**, but displaying the **SchoolID** on the form as a number in a text box is not convenient.
It would be better to offer a combo box where the user could choose a school name from a list of names.

<table>
<thead>
<tr>
<th>Task 8</th>
<th>Add a combo box for choosing which school each patient attends (if any)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>In Design View, click <img src="image" alt="Combo Box" /> then click a space where the combo box is to appear</td>
</tr>
<tr>
<td>Step 2</td>
<td>In the wizard, opt to get the values from the table <strong>tblSchool</strong></td>
</tr>
<tr>
<td>Step 3</td>
<td>Choose to display the <strong>SchoolName</strong> and <strong>Address1</strong></td>
</tr>
<tr>
<td>Step 4</td>
<td>Sort and adjust column widths as you prefer</td>
</tr>
<tr>
<td>Step 5</td>
<td>Choose to store the chosen value in the <strong>SchoolID</strong> field</td>
</tr>
<tr>
<td>Step 6</td>
<td>On the form, resize the control and edit the label as you prefer</td>
</tr>
</tbody>
</table>

## Task 9
Try using the combo box to assign schools to a few patients (not all patients go to school).

## Task 10
Plan ahead: how would you get an extra school name to appear on this list?
### Task 1
Continue working in *Woodstock Road Dentist.accdb*
Open *frmSchoolsPlain* in Form View

### Task 2
UseTABto move among the fields on the form and examine the present tab order
In Design View, change the tab order to match the form design
Try it in Form View

### Step 1
Press TAB a few times, slowly, and notice where the focus (highlight) moves among the fields
The tab order does not match the layout of fields on this form

### Step 2
Switch to Design View
On the Design tab, click

### Step 3
In the Tab Order dialog, drag the field names up and down the list, to arrange a better order
Finally, click Auto Order to allow Access to suggest an order based on the form design

### Step 4
Finish the dialog
In Form View try out the new tab order

### Task 3
Add a Form Header and Form Footer
In the Header, add a title *Schools*, and format it to be bigger

### Step 1
In Design View, click Title on the Design tab, to add a new title

### Step 2
The Header and Footer sections appear
Drag the grey horizontal dividing bars to extend the Header or Footer space

### Step 3
Select the new title object and move it to a suitable position in the Header

---

### Exercise 10  Form structure
- Reset the tab order
- Add Form Header and Footer
- Add objects in the Form Header and Footer
- Add a set of tabbed pages
- Add field controls on the tabbed pages
**Task 4**  
In the Footer, add a piece of text, with interesting colours and formats

**Step 1**  
Click in the Controls gallery then click (or drag) in the Footer to create a label

**Step 2**  
Type text such as *Enquiries to Jay Thompson* in the Footer label

**Step 3**  
Use buttons such as and from the Format tab, to apply colours and formats

**Step 4**  
Switch to Form View and see the effect of your work

**Task 5**  
Rearrange the field controls apart from Schoolname onto two tabbed pages, keeping the address information separate from the contact information

**Step 1**  
Back in Design View, select all the text boxes in the Detail, except the Schoolname  
Press DELETE to delete all these boxes

**Step 2**  
Click on the Design tab, then drag a large rectangle on the form, nearly filling the Detail section

**Step 3**  
If necessary, click to display the Fields List  
Add text box controls for the fields Address1, Address2, Address3, County and PostCode, placing them on the first tabbed page

**Step 4**  
On the second tabbed page, add more field controls, for ContactName and ContactPhone

**Step 5**  
Arrange the controls neatly

**Task 6**  
Try out the form in Form View: add a record and give some suitable data, then edit some data values in an existing record

**Step 4**  
Use the buttons on the Format tab, to make the text bigger and more eye-catching

**Step 5**  
Edit the text to read *Schools*
### Databases: User-friendly databases using Access

<table>
<thead>
<tr>
<th>Step 1</th>
<th>Test the form then close it, naming it <code>frmSchoolsTabbed</code></th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>Use <strong>Save As</strong> on the <strong>File</strong> menu to save the form, giving it the new name <code>frmSchoolsTabbed</code></td>
</tr>
<tr>
<td>Step 3</td>
<td>Close the form</td>
</tr>
</tbody>
</table>

### Exercise 11  A multiple record form
- Create a form showing multiple records
- Examine the settings that have been applied

<table>
<thead>
<tr>
<th>Task 1</th>
<th>Continue working in Woodstock Road Dentist.accdb</th>
</tr>
</thead>
<tbody>
<tr>
<td>Task 2</td>
<td>Create a new form using the Multiple Items tool</td>
</tr>
<tr>
<td>Step 1</td>
<td>In the Navigation Pane, select the table <code>tblSchool</code></td>
</tr>
<tr>
<td>Step 2</td>
<td>On the <strong>Create</strong> tab, click <strong>More Forms</strong> then choose <strong>Multiple Items</strong></td>
</tr>
<tr>
<td>Step 3</td>
<td>A new form is created</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Task 3</th>
<th>In Design View, examine the tabular layout that has been applied</th>
</tr>
</thead>
<tbody>
<tr>
<td>Task 4</td>
<td>Edit the text of the title</td>
</tr>
<tr>
<td>Step 1</td>
<td>Click in the title text box (it probably reads <code>tblSchool</code>) until you see a flashing text insertion point</td>
</tr>
<tr>
<td>Step 2</td>
<td>Edit the text to read <em>School Details</em></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Task 5</th>
<th>Adjust the sizes of the field controls</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Delete the <code>SchoolID</code> label in the Header</td>
</tr>
<tr>
<td>Step 2</td>
<td>Drag the side of the <code>SchoolID</code> text box in the Detail, to make the box much shorter</td>
</tr>
<tr>
<td>Step 3</td>
<td>Drag the side of the <code>PostCode</code> text box in the Detail, to make the box and its matching label somewhat shorter</td>
</tr>
<tr>
<td>Task 6</td>
<td>Step 4</td>
</tr>
<tr>
<td>--------</td>
<td>--------</td>
</tr>
<tr>
<td>Notice that the Default View property of this form has been set to Continuous Forms.</td>
<td>Make any further adjustments to size, arrangement or formats that you wish.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Task 7</th>
<th>Step 1</th>
</tr>
</thead>
<tbody>
<tr>
<td>In Form View, test the form. Notice the position and behaviour of the controls on this form.</td>
<td>If necessary, show the Property Sheet at the Format tab.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Task 8</th>
<th>Step 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Close the form, naming it frmSchoolsContinuous.</td>
<td>Find the Default View property. This has been set to Continuous Forms.</td>
</tr>
</tbody>
</table>

**Exercise 12  Creating and using a subform**
- Add a subform control to a form, using the wizard
- Try the form with the subform in Form View

<table>
<thead>
<tr>
<th>Task 1</th>
<th>Step 1</th>
</tr>
</thead>
<tbody>
<tr>
<td>Look at the Relationships diagram for this database. One or more patients in tblPatient are linked to each school in tblSchool.</td>
<td>Continue working in Woodstock Road Dentist.accdb.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Step 2</th>
<th>Step 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>Click on the Database Tools tab, to see the Relationships diagram.</td>
<td>Notice there is a one-to-many link between tblPatient and tblSchool. This means that a number of patients may attend the same school.</td>
</tr>
</tbody>
</table>

| Step 4 | |
|--------||
| Close the Relationships diagram using Close |
Task 2
Open `frmSchoolsWithPeople` in Design View
This will be the main form (one record per school), where you will add a subform showing the people who attend that school

Task 3
Create a new subform control
Use data from `tblPatient`
Choose `GivenName` and `FamilyName` fields
When defining which fields link the two forms, choose to use `SchoolID`

Step 1
Ensure there is a suitable space on the form, where the subform can appear
If necessary, move some controls and stretch the width of the form

Step 2
Click `法人` and drag a generous rectangle on the form
The wizard starts

Step 3
In the first part of the wizard, you choose whether to use an existing subform which you may already have built and saved, or to create a new subform
Choose to Use existing Tables and Queries

Click **Next** to move on through the wizard
Step 4
In the next part, choose the table or query which contains the records that are to be listed in the subform – choose tblPatient

Step 5
Select the fields which you want to appear in the subform – choose **GivenName** and **FamilyName**

Step 6
In the next part, the wizard offers any relationships which already exist between the two tables/queries

Unless you are sure you want to define a fresh relationship, choose the most likely definition from those offered

Choose to show records using **SchoolID**

**Tip**: if when the subform is complete it shows completely unexpected data and relationships, it is usually easier to delete the subform, check your data, then re-run the wizard to create a fresh subform, and choose carefully at this point

Step 7
In the final part of the wizard, name the subform **sfrPatientsAtSchools**

Be careful to edit the suggested name to something that conforms with the naming convention (prefix **sfr**, no spaces etc)

Click **Finish**

You are still working in **frmSchoolsWithPeople**

**Task 4**
Look at the main form in Form View, and examine the school records to see which people are at each school

**Task 5**
Leave the schools form open for the next exercise
Exercise 13  Editing a subform

- *Edit the subform in the main form*
- *Edit the subform separately*

**Task 1**
Continue working in *Woodstock Road Dentist.accdb*

Open *frmSchoolsWithPeople* in Form View (if not already open)

This is a main form (one record per school), which has a subform showing the people who attend that school

Use this form to examine the school records to see which people are at each school

**Task 2**
In Design View, drag a handle on the edge of the subform placeholder, to increase the space allowed to display subform information

**Step 1**
Note that on the record for Queen Anne Primary there are 3 patients: the subform needs a large space to display 3 or more patient records

**Step 2**
With the schools form open in Design View, click once on the subform to select it (if necessary)

**Step 3**
Drag the handle at the centre of the bottom edge, to make the subform space deeper

**Task 3**
Look at the effect in Form View, adjusting further as necessary

Close the main form, saving changes

**Task 4**
Open the subform in Datasheet View

Make some changes to column widths, font and sort order

**Step 1**
In the Navigation Pane, find *sfrPatientsAtSchools*, the subform you have just made

Open it: here it shows the full set of records in Datasheet View

**Step 2**
Drag the divider between the *GivenName* and *FamilyName* column headings, to make the *GivenName* column width fit the data

**Step 3**
Click in the *FamilyName* column and click Ascending on the Home tab

This sorts the records in ascending alphabetical order of *FamilyName*

**Step 4**
Click *Tahoma* and change the font to *Tahoma* (this will affect the whole datasheet)

**Step 5**
Close the subform, saving when prompted
### Exercise 14  Command buttons in a form
- Create a form button
- Use the wizard to set the new button to open another form
- Test the button
- Use a Quick Style to change the appearance of the button
- Change the button’s shape

### Task 1
Continue working in **Woodstock Road Dentist.accdb**
When entering details of a patient who attends school, it would be convenient to have a button that opens the form for entering school details

### Task 2
Open the form **frmPatientsPlain**

### Task 3
Add a button to the new form, which carries out the single action to Open the form **frmSchoolsPlain**

<table>
<thead>
<tr>
<th>Task 5</th>
<th>Step 1</th>
</tr>
</thead>
<tbody>
<tr>
<td>Re-open the main form in Form View and examine the subform</td>
<td>From the Navigation Pane, re-open the main form <strong>frmSchoolsWithPeople</strong> in Form View</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Step 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Look at the subform and its contents, switching between several schools’ records</td>
</tr>
<tr>
<td>Notice the effect of the changes you have made to the subform design</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Task 6</th>
</tr>
</thead>
<tbody>
<tr>
<td>Finally, close the form</td>
</tr>
</tbody>
</table>
### Databases: User-friendly databases using Access

<table>
<thead>
<tr>
<th>Step 6</th>
<th>Choose the picture offered for the button</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 7</td>
<td>Accept the suggested button name and finish the wizard</td>
</tr>
</tbody>
</table>

**Task 4**

Save the form

In Form View, click the button and see that it opens another form

**Task 5**

Apply a Quick Style to the button and change the shape

<table>
<thead>
<tr>
<th>Step 1</th>
<th>Close the Schools form</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>View the Patients form again, in Design View</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Step 2</th>
<th>With the new button selected, click on the Format tab</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Step 3</th>
<th>Choose a colour and appearance that you think will look good in the form</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Step 4</th>
<th>Click and change the button into a rounded rectangle</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Step 5</th>
<th>Try out the button in Form View</th>
</tr>
</thead>
</table>

**Task 6**

Close all forms, saving changes if asked

Close the dentists database, leaving Access open

---

**Exercise 15 Creating macros**

- Run a macro from the Navigation Pane
- Build a simple macro
- Run a macro from the Database Tools tab anywhere

**Task 1**

Open `Inventory.accdb`

Look at the Relationships diagram to discover the tables and their links

In this database, an administrator is looking after a collection of equipment, each of which is assigned to a department
### Task 2
Look at Macros listed in the Navigation Pane and run `
mcrOpenFormMax`

<table>
<thead>
<tr>
<th>Step 1</th>
<th>Look at the list of macros in the Navigation Pane</th>
</tr>
</thead>
</table>
| Step 2 | Either select `mcrOpenFormMax` and press ENTER or double-click the macro name.  
This macro will open a form, then display messages explaining which record it is showing. |
| Step 3 | Close the form |

### Task 3
Create a new macro which opens the report `rptAllAssets` with the filter `qryMaintenancePlan` in Print Preview view

<table>
<thead>
<tr>
<th>Step 1</th>
<th>Click on the Create tab, to start creating a new macro</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>In the first, choose from the drop-down list the Action <code>OpenReport</code>. In the parameters, select the report name <code>rptAllAssets</code>.</td>
</tr>
<tr>
<td>Step 3</td>
<td>In the View box, select Print Preview</td>
</tr>
<tr>
<td>Step 4</td>
<td>In the Filter Name, type <code>qryMaintenancePlan</code>. This query has been created already. This query uses criteria to select only some of the records</td>
</tr>
</tbody>
</table>

### Task 4
Include a message box with a suitable greeting

<table>
<thead>
<tr>
<th>Step 1</th>
<th>Look in the Action Catalog. Explore the way that the actions are presented in categories</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>As the next Action, choose MessageBox</td>
</tr>
<tr>
<td>Step 3</td>
<td>In the parameters: Give a helpful message such as This report shows all the assets. Choose the Type Information. Give a dialog title Asset Inventory</td>
</tr>
</tbody>
</table>
### Task 5
Save the macro as *mcrAssetsForMaintenance*
Run the macro using the **Database Tools** tab

| Step 1 | Close the macro  
| Save it, giving the name **mcrAssetsForMaintenance** |
| Step 2 | Click on the **Database Tools** tab  
| In the Run Macro dialog, choose **mcrAssetsForMaintenance** |
| Step 3 | Close the report and any macro windows |

### Exercise 16  More macro commands (Optional)
- *Edit a macro*
- *Add an action that hides the Navigation Pane*
- *Insert a command that is usually found on the Access menus*
- *Rearrange the order of commands*

#### Task 1
You might prefer that your users do not see the Navigation Pane, and that instead you will provide buttons that they would use for navigation
For this, suppose that you have decided that one of the macros should close the Navigation Pane

| Step 1 | Continue work in **Inventory.accdb**  
| Look at the list of macros in the Navigation Pane |
| Step 2 | Right-click **mcrOpenFormMax**, and choose Design View to open it in the Macro Designer |
| Step 3 | Read through the steps in this macro, to discover what it does |

#### Task 2
Open **mcrOpenFormMax** for editing

| Step 1 | Click **Add New Action** |
| Step 2 | Choose **RunMenuCommand** from the list of macro actions |
| Step 3 | In the Command box, choose **WindowHide** |
Review the steps in the macro, thinking about the sequence

**Step 1**
Notice that the `WindowHide` command is the last one in the sequence

**Step 2**
If the `WindowHide` action is carried out last, it will hide the form that has just opened, which is not useful

**Step 3**
You need the `WindowHide` action to hide the Navigation Pane, so it needs to be the first action, carried out before the form is even opened

Rearrange the actions in the macro, so that the Navigation Pane is the window that will be closed

**Step 1**
Drag the `RunMenuCommand` action, and drop it near the top of the macro, after the beep

**Step 2**
Save the macro and test it

**Step 3**
Note that your users can manually show the Navigation Pane again by pressing F11

---

**Exercise 17  Macros in a form**

- *Set an existing macro to run on opening a form*
- *Test it*
- *Add a button in a form, to run a macro*
- *Test it*

**Task 1**
Set the macro `mcrGoToRecord` to run when `frmAllAssets` is opened

**Step 1**
Continue work in `Inventory.accdb`
Open `frmAllAssets` in Design View

**Step 2**
Display the form’s properties:
- click and click the form selector button (square space where the two rulers meet)

**Step 3**
On the **Event** tab of the Property Sheet, click opposite the **On Open** event
Choose `mcrGoToRecord`

**Step 4**
Close the form
### Task 2
Run `frmAllAssets` and confirm that the macro has run

This macro maximizes the form, then moves immediately to the first record, which has a Serial Number of 576345

### Task 3
Add a button on `frmAllAssets` to run the macro `mcrChangeVisibleProperty`

Give the button text **Hide A Control**

### Step 1
Switch to Design View

Click and click in a space in the form

The wizard starts

### Step 2
Make these choices in the wizard:
- In the Categories, select **Miscellaneous**
- In the Actions choose **Run Macro**
- In the list of macros, choose `mcrChangeVisibleProperty`

### Step 3
Type text for the button: **Hide A Control**

Accept the suggested button name

### Task 4
Save then run the form

Click the new button and see what the macro does

### Task 5
Close the form, saving changes

---

### Exercise 18  Building a navigation form

- *Create a blank navigation form*
- *Add a button, which opens another form*
- *Add more buttons for opening forms and reports*

### Task 1
Continue work in **Inventory.accdb**

### Task 2
Create a new blank form

Name it **frmWelcome**

### Step 1
In the Create tab, click ![Navigation](image)

Choose **Vertical Tabs, Left**
### Exercise 19  Improving the look of a navigation form

- *Format the navigation buttons*
- *Improve the text of navigation buttons*
- *Improve other text on the form*
- *Add a button for exiting the application*

### Task 1
Continue work in the database *Inventory.accdb* in *frmWelcome*, in Layout View

### Task 2
Change the appearance and shape of the buttons

**Step 1**
Select the Assets navigation button (click once, to see an orange border around the button)

**Step 2**
Click on the *Format* tab, and choose a different Quick Style for the button
| Task 3 | Step 1 | Select the Assets button if necessary  
| Task 4 | Step 1 | Display the Property Sheet: click on the Design tab  
| Task 5 | Step 1 | Switch to Design View  
|        | Step 2 | In the Form Header, resize the title object to leave some space at the top right corner  
|        | Step 3 | Click to start the Command Button wizard  
|        | Step 4 | Drag a button shape in the space in the Form Header  
|        | Step 5 | Choose Application and then Quit Application (type Goodbye or suitable text)  
|        | Step 6 | Format the new command button to match the others  
| Task 3 | Step 2 | Click a second time on the button, to see a flashing text insertion point  
|        | Step 3 | Edit the button text to say Details of equipment  
| Task 4 | Step 2 | Use the drop-down control at the top of the Property Sheet to display the properties of the form itself  
|        | Step 3 | On the Format tab of the Property Sheet, type Welcome in the Caption  
|        | Step 3 | Edit the other buttons to have more familiar text  
| Task 5 | Step 4 | Use the Format Painter to make all the other navigation buttons match the one you have formatted  
|        | Step 4 | Improve the text shown on the buttons  
| Task 5 | Step 5 | Choose Application and then Quit Application (type Goodbye or suitable text)  
|        | Step 6 | Format the new command button to match the others
### Task 6
Save the form and try out all the buttons in Form View

### Exercise 20  Startup options
- Make a startup form
- Display a custom title for the application in the title bar
- Hide the Navigation Pane
- Try the startup options
- Over-ride startup options

### Task 1
Continue work in `Inventory.accdb`

### Task 2
Among the Current Database category of the Access Options, set:

- **Display Form/Page** is `frmWelcome` (or any other form you would choose for starting)
- **Application Title** is `Rapid Equipment Supplies Ltd`

### Step 1
On the **File** menu, click **Options**

### Step 2
Click **Current Database** in the category list on the left

### Step 3
Set the **Display Form** to be the navigation form `frmWelcome`
(Note: If this form does not yet exist, you could make it following the instructions in Exercise 18 or nominate another available form)

### Step 4
In the **Application Title** box, type `Rapid Equipment Supplies Ltd`

### Step 5
Under **Navigation**, clear the **Display Navigation Pane** checkbox

### Step 6
Close the Options dialog

### Task 3
Close the `.accdb` file and re-open it to see the startup options

### Step 1
Click **Close** in the **File** menu to close `Inventory.accdb`

### Step 2
Open `Inventory.accdb` using **Open** on the **File** menu

### Step 3
The welcome form opens immediately, the Navigation Pane is hidden and the alternative text appears in the Access title bar
### Task 4
Use SHIFT to re-open the file normally

<table>
<thead>
<tr>
<th>Step 1</th>
</tr>
</thead>
<tbody>
<tr>
<td>Close <em>Inventory.accdb</em></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Step 2</th>
</tr>
</thead>
</table>
| Open *Inventory.accdb* once again, while holding down SHIFT  
This time the welcome form does not open automatically, and the alternative text does not appear in the Access title bar |

### Task 5
Finally, close everything

<table>
<thead>
<tr>
<th>Step 1</th>
</tr>
</thead>
<tbody>
<tr>
<td>Finally, close the database file and close Access</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Step 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Leave the computer at the desktop</td>
</tr>
</tbody>
</table>
Databases: User-friendly databases using Access

Today’s arrangements

Your teacher is:  
Your demonstrators are:  

We finish at: 12:15

Your safety and comfort are important

Where is the fire exit?  
Please report any equipment faults to us  
The toilets are along the corridor outside the teaching rooms  
The rest area is where you registered; it has vending machines and a water cooler

The course handbook

Tasks for you to practice during today’s course  
Work at your own pace!  
Divided into tasks and small steps  
Be selective  

Follow-up work  
Continue with exercises after the session  

Course Clinics

Road map for “User-friendly databases”

Getting Started
Getting started with Access

Start Access
Use a desktop icon or Start menu etc.

Access version 2013 in teaching rooms
Enabling active content? (see appendix in the course book)

Opening a database file

Today, the exercise files are in your network drive H:\

Creating a Form

Forms are used for entering and editing data

A form presents data from the table
Laid out suitably for using on computer screen
Typically show one record at a time
Good layout helps the user to enter data accurately
Type-in boxes, drop-down list boxes and other controls are easy to use

Creating a form using the wizard

Wizard steps you through creating a simple form
Give a name
Form names begin with _frm_
No spaces and limited punctuation

Using a form

Available forms are listed in the Navigation Pane
When a form is run, Access takes the up-to-date values from the tables
Navigate between fields and records
Edit data values
3 views of a form

- **Form View**: Editing the data using the form
- **Layout View**: Sample data is visible but not editable (Rearranging the form)
- **Design View**: No data values (Detailed design changes later course)

Creating a blank form

**Create** a new form in Design View

Gridlines help with layout

Save the form

Form names conventionally begin with `frm`

**Objects in a Form**

**Adding objects onto a form (using the Design tab)**

- Add graphic objects: a line or rectangle
- Add a label
- Add the first field control
  - Binds the form to the table
- Add more field controls
  - Each text box is bound to a field

Try the form in Form View

**Manipulating a text box**

- Each text box control has a label
- Click a control or a label to select it
- Drag a control to move
- Drag an edge to resize
- Edit text inside a label

**Working with multiple controls**

- Selecting multiple controls
  - Hold Ctrl key then click several objects
  - Or drag an enclosing rectangle
  - Or drag on a ruler

- Arranging multiple controls
  - Overlapping objects have a stack order

- Useful tools for positioning and aligning
Databases: User-friendly database

Look at Exercises 1 to 5
Drinks and food in the refreshment area only, please

Demonstrator
Restart at 10:15

If you want to continue with the Exercises, you could...

Copy the Exercise files to a memory stick
Download the files (and more) from the ITLP Portfolio at http://portfolio.it.ox.ac.uk

Modifying a Form’s Design

Theme transforms the form

Quickly change the whole look of a form using the Theme Gallery

Buttons for popular formatting options

Font formatting
Colours, lines and fills
Number, date formatting
Conditional formatting

The Property Sheet

More properties for form controls
A form itself has properties
Record source for its data
Scroll bars, buttons etc
Adding More to a Form

Adding other types of control
- Check box for a Yes/No field
- Combo box for a field with a lookup
- Date picker for a Date field

Adding an option group (optional)
- Option group offers a few choices
  - Options may have friendly text labels
  - Always inputs a number into table

A combo box offers choices
- Built using the Combo Box wizard
  - Choose where the list items will come from
    (table, query, typing in)
  - Choose a field where the values are to be stored
- Properties of a combo box
  - Allowing other values?
  - Adding an item to the list
- Combo box for navigating records

Make the form easy to use
- Tab order
  - Rearrange for a more convenient field order
- Tabbed pages (extra pages on a form)
  - Insert more pages
  - Name property to show better text on the tabs
- Header and Footer
  - Automatically appear when title or logo is inserted

Form Structure
A form with many records

A Multiple Items form
Continuous Forms view
Similar layout to datasheet view, but with easy-to-use form controls

Subforms

Why use a subform?
To show a one-to-many relationship

Create a subform from within a form
Subform names begin with sfr
Resize as necessary

Using and editing a subform

Use the subform from inside the main form
Only related records are shown in the subform
2 sets of record navigators

Edit a subform directly
Open it from the Navigation Pane

Databases: User-friendly database

Look at Exercises 6 to 13
Be selective - choose the exercises you need
Drinks and food in the refreshment area only, please
Restart at 11:15

User interface

Trusting the File Location (Optional)

On the File menu, click
Select the Trust Center and
Select Trusted Locations and

IT Learning Programme
**A button on a form**

In Design View:
Add a Button
The wizard starts
Choose a category and an action
Choose button face (text or picture)
Format the button
colour, shading, shape using buttons
Or Quick Styles
User can click the button when ready

**Building a macro**

Create a new macro
Choose an Action in the first row
Give Parameters for the Action
Add more Actions in further rows
Save - macro names begin mcr

**Running a macro**

Macros are listed in the Navigation Pane
Double-click the macro name
Or use on the Database Tools tab
Choose a macro by name from the list

**Attaching a macro to a form/report (Optional)**

In Design View, show the Form/Report Properties
On the Event tab, choose an event, such as On Activate
Choose a macro name from the list
Try it out: when the form/report is started, the macro is run

**Command button to run a macro**

Use the Command Button wizard
Macro name - choose from the list
User decides when to click the button and start the macro

**A navigation form**

Drag a form name from the Navigation Pane
Drag other forms and reports
Format the buttons, improve the text
Hide all window control tools on all the forms (min/max, close etc.)
May create a blank “front page”
Databases: User-friendly databases using Access

A display form

A form that appears when the file opens

Among the File Options for the Current Database
- Set a display form
- Suppress other features
- Hide the Navigation Pane

Over-ride: hold Shift key while opening a file

Publish the database (Optional)

Among the Options for the Current Database
- Hide the Navigation Pane
- Compact on Close
- Set a password for the database
- Open exclusive
- File Info
- Executable-only version of the database
  Save As | Make .ACCDE

More about databases

Further courses

Further work with Access:
- Reporting on database data
- Querying and analysing data

Problems:
- Course Clinic
- help@it.ox.ac.uk
- Help centre appointments Monday-Friday

If you want to continue with the Exercises, you could ...

Copy the Exercise files to a memory stick
Download the files (and more) from the ITLP Portfolio at http://portfolio.it.ox.ac.uk

Databases:
User-friendly database

Look at Exercises 14 onwards
Drinks and food in the refreshment area only, please

We finish at 12:15